#7951

Yutaka Emura
Keymaster

Klortho wrote:
Hi, I just installed the portable version, and I’m trying to put all my macros in a “macros” subdirectory of the installation directory. That way, I can have everything in one place.
The problem is illustrated by this sequence of steps:
1. I copied my macro “XMLEscape.jsee”, into the “macros” subdirectory of the EmEditor directory where I have the portable version
2. I selected the menu option “Macros” – “Select”, and navigated to the file and clicked “Open”,
3. In the “Macros” menu, I now see my macro listed as item # 2.
4. If I try to click on it, though, I get a box saying “The system cannot find the file specified. macrosXMLEscape.jsee”

I checked in the eeCommon.ini file, and found that the setting is
MacroFile=macrosXMLEscape.jsee
which is clearly wrong, the path shouldn’t start with “” — it should be relative.

If I change that to remove the leading “”, and then restart EmEditor, then I can access the macro.

The same problem occurs when you try to customize the macro menu through “Macros” – “Customize…”. If I click “New” and add macros using that box, then they appear in the menu, but clicking on them has the same problem. I found that to make the change permanent, so that these macros are always available from the “Macros” menu, I had to change the pathnames under the [Macros] section of the same .ini file.

I cannot reproduce your issue, so it might depend on OS version. Which OS do you use? Windows XP or Vista? Do you use the latest version of EmEditor — 9.06?