Thank you for your reply, but the thing is that the “In the selection only” is unchecked even if i have many lines selected when i press CRTL-H for replace. I’m pretty sure it worked according to your explanation in version 9.15. Now i’m using 9.16 and there is no way i can make this checkbox selected by default no matter how many lines i have selected.

I believe the setting to turn this feature on/off isn’t really needed in my case as long as it’s working according to your explanation. Currently i can’t make it work with 9.16 though.

Edit: I did some more testing and seems like it’s working as you describe if i also have “Use selected Text in Find/Replace dialog box” selected. As soon as i uncheck the “Use selected Text in Find/Replace dialog box” setting it’s not working anymore with the automatic selection of “In the selection only”.
I would like to have the “In the selection only” checked automatically, but i don’t want the “Use selected Text in Find/Replace dialog box” enabled.