Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #8383

    gan
    Participant

    Is there any setting in emeditor so when i have more than a certain characters/lines already selected the replace dialog will check “In the selection only” by default?
    I’m sure i have seen this setting before, but cannot find it or i’m wrong and thinking about another editor.
    If such a feature does not exists i would suggest to add that feature which seems to be pretty common among other editors.

    By the way i’m using version 9.16.

    gan

    #8384

    Yutaka Emura
    Keymaster

    I don’t think there was the setting for this purpose, but the “In the selection only” option will be checked automatically if you select more than one line of the text before you display the “Replace” dialog box. However, if the selection does not include a new line (if the selection is only one line), then this check box will not be checked automatically. I hope this makes sense to you.

    If you have further questions, please don’t hesitate to ask me. Thank you!

    #8386

    gan
    Participant

    Thank you for your reply, but the thing is that the “In the selection only” is unchecked even if i have many lines selected when i press CRTL-H for replace. I’m pretty sure it worked according to your explanation in version 9.15. Now i’m using 9.16 and there is no way i can make this checkbox selected by default no matter how many lines i have selected.

    I believe the setting to turn this feature on/off isn’t really needed in my case as long as it’s working according to your explanation. Currently i can’t make it work with 9.16 though.

    Edit: I did some more testing and seems like it’s working as you describe if i also have “Use selected Text in Find/Replace dialog box” selected. As soon as i uncheck the “Use selected Text in Find/Replace dialog box” setting it’s not working anymore with the automatic selection of “In the selection only”.
    I would like to have the “In the selection only” checked automatically, but i don’t want the “Use selected Text in Find/Replace dialog box” enabled.

    gan

    #8388

    Yutaka Emura
    Keymaster

    Hello gan,

    Thanks so much for additional information.

    I reproduced your issue, and I will fix it on the next beta version of v10.

    Thanks again,

    #8389

    gan
    Participant

    Thank you Yutaka. Since i currently don’t use the version 10 beta, will there also be a 9.17 release where this issue is fixed?

    gan

    #8391

    Yutaka Emura
    Keymaster

    Hello gan,

    I am sorry but we are not sure if we release 9.17. We rather would like to release v10 as soon as possible since v10 includes all previous bug fixes plus many new features. v10 will be available free for v9 users.

    Please let me know if you have further questions. Thank you!

    #8392

    gan
    Participant

    If version 10 is to be released in the close future that’s fine, but if version 10 are months away i’m hoping for a 9.17.

    Thanks
    gan

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone