Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #25851

    TianCheng Yu
    Participant

    The new versions of EmEditor’s toolbar (focus) animation is looking a bit weird for me.
    Gif

    Is it possible to add an option to disable / change the animation to the style like Windows notepad / Older version of EmEditor?

    #25852

    TianCheng Yu
    Participant

    The fade-in and fade-out of the texts are very distracting

    #25853

    Patrick C
    Participant

    Interesting I haven’t got this behaviour.

    Have you tried setting
    Tools → Customise Menus… → Delay time
    to 0.0 seconds ?

    Cheers
    Patrick

    #25855

    TianCheng Yu
    Participant

    Thanks. But it is set to 0.0 second.

    #25856

    Yutaka Emura
    Keymaster

    Actually, I am not sure what the issue is. Can you please describe the issue more in details?

    In Windows System Properties > Performance > Visual Effects dialog, can you try different options (such as “Animate controls and elements inside windows”)?

    #25858

    TianCheng Yu
    Participant

    I tried turn on and off visual effects in Windows, there is no difference about this behaviour.

    The effect when the mouse is hovered on a toolbar menu, the background becomes blue and text becomes white is distracting (hard to read the text when the animation is playing).

    It would be better if there is an option to use the behaviour like toolbar (the Print button has the mouse hovered), like Windows Notepad:

    Notepad behaviour

    i.e. only make the background deeper with a rectangle around the button, but not changing the color of the menu text.

    #25859

    TianCheng Yu
    Participant

    Maybe this is due to that the animation does not change the entire text’s color at same time?

    Here is a screenshot in the middle of the animation:

    This behaviour is especially obvious and uncomfortable when using high refresh rate monitors.

    Because it only happens in few frames, it may be imperceptible on normal 60 Hz monitors.

    #25860

    TianCheng Yu
    Participant

    The animation when mouse is hovered on seemed correct for me, no such glitch happen.

    The issue only exists when the mouse leaves (the menu loses focus).

    #25861

    Yutaka Emura
    Keymaster

    Which version of Windows do you use? Windows 10?
    Can you try different colors or themes on Windows? Can you try the default Windows theme?

    #25862

    TianCheng Yu
    Participant

    I am using Windows 10 1803 (17134.799). The theme is default theme, only color changed.

    The Windows default theme gives the same result.

    #25863

    TianCheng Yu
    Participant

    I tried this on my laptop and there is no issue at all. Probably it is due to some weird corrupted system setting…

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.