Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4776

    xxx_pic
    Member

    Sometimes, I typed something and the document’s Caption displayed a “*” , but the “Save” command on the toolbar or menu still disabled !

    #4795

    Yutaka Emura
    Keymaster

    xxx_pic wrote:
    Sometimes, I typed something and the document’s Caption displayed a “*” , but the “Save” command on the toolbar or menu still disabled !

    I have not had this issue before. When you see next time, please let me know how you can reproduce this problem. I need to reproduce your problem on my machine too to fix this. Thanks!

    #4921

    xxx_pic
    Member

    It happened again!
    When I open many asp files with EmEditor (I used about 1~2 hours) and many other programs: Excel 2003, Access 2003, IIS Manager, UEStudio, MyIE Browser .

    I’am not sure when to happen!

    Last time happened, I remembered , when I edit some BAT files for many hours , and use the Virtual PC to run those BAT files again and again .

    #4929

    xxx_pic
    Member

    I think that should update the * mark and the toolbar’s “Save” button or menus’ “Save” commands together to fix it.

    You may check out your Emeditor’s source code around updating the document’s caption of the * mark , to add some code to update the toolbar and menu.

    #4930

    Yutaka Emura
    Keymaster

    xxx_pic wrote:
    I think that should update the * mark and the toolbar’s “Save” button or menus’ “Save” commands together to fix it.

    You may check out your Emeditor’s source code around updating the document’s caption of the * mark , to add some code to update the toolbar and menu.

    What version of EmEditor are you using? Are you using the latest version? I cannot fix the issue unless you explain more details about the issue and how to reproduce the issue.

    #4931

    xxx_pic
    Member

    [beta28] It happened again, when I edited only 3 asp files !

    I right-clicked on the document’s tab button shown the popup menu that “Save” command was enabled, but the main toolbar’s “Save” icon and the main menu’s “Save” command were still disabled !

    I think it may be on your source code somewhere forget to refresh the main toolbar and main menu, when the documents’ tab button shows a * mark.

    Sometimes it happened after I dragdrop a file to EmEditor , then i click the tab button to switch to other document and edit .

    #4932

    Yutaka Emura
    Keymaster

    What OS are you using? It might be helpful if you can send me a screenshot of the issue at tech@emurasoft.com Thanks!

    #4990

    xxx_pic
    Member

    How about give user an option to turn the “Save” command always enabled ?

    Currently, EmEditor cannot “Save” a document while the document is “Empty” and without any changed (Just used the “New” command or just clicked EmEditor’s shortcut from Start Menu) .

    However , The Windows NotePad can “Save” anytime I want !

    #4993

    Yutaka Emura
    Keymaster

    xxx_pic wrote:
    How about give user an option to turn the “Save” command always enabled ?

    Currently, EmEditor cannot “Save” a document while the document is “Empty” and without any changed (Just used the “New” command or just clicked EmEditor’s shortcut from Start Menu) .

    However , The Windows NotePad can “Save” anytime I want !

    You can always enable saving from Configuration Properties – File tab – Saving button – “Always Enable Saving” check box.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone