Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #4788

    titieye
    Participant

    Maybe it isn’t a bug.

    I dump a MySQL database to a SQL file and open the file with EmEditor. then I find it’s hard to scroll down. something make the editor locked.

    Then I open the file with windows notepad and find a super long line content like this:

    insert into some_table(a,b,c,d) values (1,2,3,4), (5,6,7,8),………..

    it’s export from a db, there thousand of (1,2,3,4)s in that line. the notepad still can scroll normally.

    the above is how i find this. Can EmEditor deal with a super long line?

    #4790

    titieye
    Participant

    I try many other editors, major of them can’t deal with this case. but only the Microsoft Visual Studio 2005 give me a alert dialogue like this

    —————————
    Microsoft Visual Studio
    —————————
    One or more lines are too long in this file. These lines will make the editor slow when you open the file. Do you still want to open it the file?
    —————————
    Yes(Y) No(N)
    —————————

    this way’s better.

    #4791

    Yutaka Emura
    Keymaster

    In EmEditor, there is no limit in length of a line, so there is no message box needed. I guess you should try with “No-Wrap” mode and also disable any highlight (uncheck “Highlight These Words” on the Highlight (1) tab of properties). If you still have the issue, please zip the sample file and email to tech@emurasoft.com as an attachment. Thanks!

    #4793

    titieye
    Participant

    I’ve sent the sample file, thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone