Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #5898

    tslim
    Participant

    Hi,
    I am evaluating the latest ver of EmEditor 7.0.0.9
    I am running English WinXP+Sp3, non-unicode language is set to “Chinese PRC”

    Question1:
    How do I configure EmEditor such that it automatically open a text file under “English” encoding if the text file contains only English texts (no Chinese or other language character) and automatically open text file under a unicode encoding if a text file contains mix languages content?

    Question2:
    What is “Configured Encoding” under File->Saving->Encoding setup?

    #5899

    Yutaka Emura
    Keymaster

    tslim wrote:
    Hi,
    I am evaluating the latest ver of EmEditor 7.0.0.9
    I am running English WinXP+Sp3, non-unicode language is set to “Chinese PRC”

    Question1:
    How do I configure EmEditor such that it automatically open a text file under “English” encoding if the text file contains only English texts (no Chinese or other language character) and automatically open text file under a unicode encoding if a text file contains mix languages content?

    Question2:
    What is “Configured Encoding” under File->Saving->Encoding setup?

    There is no “English” encoding, but there is Western European (iso-8859-1) encoding. You can check “Detect All” when you open a file, or check “Detect All” in the File tab of Configuration Properties. However, nothing is perfect to detect the correct encoding of files you open, so you might need to “Reload” with the correct encoding after you open files, by double-clicking the encoding in the status bar.

    “Configured Encoding” is the encoding used to open the file. It should be labeled “Same Encoding”

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.