Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #7438

    Yutaka Emura
    Keymaster

    EmEditor Professional 9.00 alpha 33 is available for download.

    Updates from alpha 32 include:

    – Fixed bugs related to auto workspace.
    – Fixed bugs related to CSV mode.

    Please download

    http://www.emeditor.com/pub/emed900a33epx.msi (English, 32-bit)
    http://www.emeditor.com/pub/emed900a33ep64.msi (English, 64-bit)

    The portable version can be produced from the Import/Export wizard on the Tools menu after you use the installer. However, the portable version runs slower than the one using the Registry.

    The Help has not been updated. Please let me know earlier rather than later if you have any bug reports or comments. Thanks!

    #7440

    CaptainFlint
    Participant

    Two problems:

    1. EE 9 does not restore the window position. Tried with beta 29 and 33, WinXP SP3 Pro. I open EE, maximize it, go to Customize -> Window, check Restore Window Position, press the Save Current Window Position button, close EE. Then I double-click a TXT file -> EE opens again with non-maximized window.

    2. When I start EE, its window has black corners on the top. After the window size/position is changed, they disappear. I recorded a video:
    Video/EXE (player/codec included)
    Video/AVI (needs MSU Screen Capture Lossless Codec)

    #7441

    Yutaka Emura
    Keymaster

    When you click the Save Current Window Position button, you will also have to click the Save Current Window Position. Also, if you have the tabs enabled, the “Restore Tabbed Window Position” also does the trick.

    I have trouble downloading your video files, so I will try again. Thanks!

    #7442

    CaptainFlint
    Participant

    When you click the Save Current Window Position button, you will also have to click the Save Current Window Position.

    Sorry, what do you mean? You named the same button twice…

    Also, if you have the tabs enabled, the “Restore Tabbed Window Position” also does the trick.

    Yes, tabs are enabled, and the Restore Tabbed Window Position is checked here. Or do I need to uncheck it?

    I have trouble downloading your video files

    Strange, no problem here. OK, I reuploaded them to Rapidshare: EXE, AVI

    #7455

    Yutaka Emura
    Keymaster

    Flint wrote:

    When you click the Save Current Window Position button, you will also have to click the Save Current Window Position.

    Sorry, what do you mean? You named the same button twice…

    Also, if you have the tabs enabled, the “Restore Tabbed Window Position” also does the trick.

    Yes, tabs are enabled, and the Restore Tabbed Window Position is checked here. Or do I need to uncheck it?

    I have trouble downloading your video files

    Strange, no problem here. OK, I reuploaded them to Rapidshare: EXE, AVI

    Sorry, I mean when you click the Save Current Window Position button, you will also have to click the Restore Window Position check box. And I know you are all set.

    The Restore Tabbed Window Position should be unchecked if you want the window open maximized even if you close in non-maximized size.

    Please make sure to disable “Automatic Workspace” (select off or Save Only) because the workspace includes information about window sizes.

    I downloaded your video files. It looks strange. Did you try on the Windows Desktop?

    #7456

    CaptainFlint
    Participant

    It seems I found the source of the problem. I have a macro autorunning on “File Opened” event (for extended associations processing). When I turn the “Runs at Events” checkbox off, then both problems (non-restoring of the window and black triangles) are gone!

    #7457

    CaptainFlint
    Participant

    Also, one more problem appeared: when I turned the “Runs at Events” checkbox on again, EmEditor does not find the macro anymore. Each time I opens a file, the message appears:

    —————————
    EmEditor
    —————————
    The system cannot find the file specified.

    C:Program FilesEmEditorExtendedAssociations.jsee
    —————————
    OK
    —————————

    EE tries to look for the macro in wrong directory…

    #7460

    Yutaka Emura
    Keymaster

    Flint wrote:
    Also, one more problem appeared: when I turned the “Runs at Events” checkbox on again, EmEditor does not find the macro anymore. Each time I opens a file, the message appears:

    —————————
    EmEditor
    —————————
    The system cannot find the file specified.

    C:Program FilesEmEditorExtendedAssociations.jsee
    —————————
    OK
    —————————

    EE tries to look for the macro in wrong directory…

    Do you use the Registry or use INI files?

    #7463

    CaptainFlint
    Participant

    Registry.

    #7464

    Yutaka Emura
    Keymaster

    Flint wrote:
    Registry.

    I reproduced this problem, and it will be fixed on next alpha version. Thanks!

    #7474

    CaptainFlint
    Participant

    I confirm that EE 9α36 now correctly finds the macro on File Opened event.

    However, the other two problems still remain (not restoring the window position, and black corners of the newly created window).
    I checked: both these problems can be reproduced only when I turn on the option for running my macro on File Opened event. When I turn it off, both problems disappear.

    #7476

    Yutaka Emura
    Keymaster

    Flint wrote:
    I confirm that EE 9α36 now correctly finds the macro on File Opened event.

    However, the other two problems still remain (not restoring the window position, and black corners of the newly created window).
    I checked: both these problems can be reproduced only when I turn on the option for running my macro on File Opened event. When I turn it off, both problems disappear.

    This will be fixed on alpha 37. It you still see the balck corners on alhpa 37, please let me know again.

    #7492

    CaptainFlint
    Participant

    I tested 9α37 and confirm that both issues are fixed when File Opened macro event is used. Black corners are not shown, and maximized window position is restored. Thank you!

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone