Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #9629

    Yutaka Emura
    Keymaster

    EmEditor Professional v11 RC 1 (10.9.2) is available for download.

    The updates from beta 2 include:
    – Unicode Ideographic Variation Sequence (IVS) is now supported. (Supporting fonts are needed.)
    – UI language translations except Russian and Traditional Chinese.
    – Bug fixes.

    New features include Markers, Tooltip to show HTML/XML character references, Find toolbar, and Batch Replace.

    For details of new features and screenshots of EmEditor Professional 11, please see:
    http://www.emeditor.com/modules/feature1/rewrite/tc_39.html

    Please download:
    http://www.emeditor.com/pub/emed32_10.9.2.exe (32-bit)
    http://www.emeditor.com/pub/emed64_10.9.2.exe (64-bit)

    These versions work with your registration key for v10.

    Supported OS: Windows 7/Vista/XP/2000 SP4/Server 2008/Server 2003

    The portable version can be produced from the Import/Export wizard on the Tools menu after you use the installer. However, the portable version runs slower than the one using the Registry.

    EmEditor Professional 11 is available free for all users who have purchased EmEditor Professional v4 – v10 and registered the product before November 1, 2011 at Emurasoft Customer Center! To read the entire news, please see: http://www.emeditor.com/modules/news/article.php?storyid=101

    Please don’t hesitate to write any comments or bug reports in this forum.

    Thank you for trying EmEditor beta versions!

    #9630

    Athan
    Participant

    Thanks Yutaka for the RC1 release.

    It seems you missed the following two issues I reported last month.

    1. HTML Toolbar color selector: Select any string in current document (e.g. a color value). Open color selector from html toolbar, select any color and press OK. New color value is inserted in front of the selected text instead overwriting it.

    2. “Find in files” dialog is not resizable. Shouldn’t be like “Find” and “Replace” dialogs?

    Thanks!

    #9631

    Yutaka Emura
    Keymaster

    Hi Athan,

    These are not bugs, and I decided not to work on these issues at this version. Maybe I will consider these in future versions.

    Thanks for trying EmEditor RC 1 so soon!

    #9632

    Athan
    Participant

    Fair enough, I’m sure I can live with these minor issues.

    Thanks!

    #9633

    CaptainFlint
    Participant

    After installing RC1 I discovered the following issue:

    1. Close all EmEditor instances if any.
    2. Open EmEditor (empty “Untitled” document).
    3. Double-click any text file in Explorer window – nothing happens, the file is not opened in EE.

    I also tried starting EmEditor from command line specifying a file to open, and dragging a file from Explorer into EmEditor window – both methods did not work. The only way to open a document from outside is to close this “Untitled” EE instance and then double-click the file.

    My OS is Windows Vista Business 32-bit.


    And one more issue. I’m using English interface on a Russian Windows, and I noticed that the “Customize Toolbar” window is localised: all the text labels and buttons are translated into Russian. I know this could happen if it were a standard Windows dialog “borrowed” by EmEditor from the system, but is it really such a dialog, or just a EE glitch with localisations?

    #9635

    Yutaka Emura
    Keymaster

    Hi Flint,

    I can’t reproduce your issue. It seems your txt file associations are not correct.
    Can you try associating another file extension (such as .log) from the EmEditor tools menu, Customize, File tab, click Associate with EmEditor button, and then add .log to the list. Then please try opening from Explorer. If this works and if .txt doesn’t work, you might want to remove .txt from the association list, and add again. You can also try uninstalling EmEditor completely, and the try installing EmEditor again.

    I hope this helps.

    P.S. The “Customize Toolbar” dialog is a part of the OS.

    Thanks!

    #9637

    CaptainFlint
    Participant

    As I wrote, associations didn’t matter. I just opened the cmd.exe console and wrote something like:

    "c:Program FilesEmEditorEmEditor.exe" "c:Program FilesEmEditortemplate.xml"

    and it did not work.

    But I found what the source of the problem was: the EmEditor instance that was running on my machine was elevated because I didn’t untick “Launch EmEditor” checkbox on the installer’s last page, and it ran EmEditor with the current installer’s privileges. Later when I was reproducing the issue, I started EmEditor from PowerPro. PowerPro itself is running elevated, but I set the “Run as normal user” checkbox in it. However, there seems to be a problem in PowerPro itself and this option does not work: EmEditor starts elevated despite of this option. I did not notice this at first, so I thought it was something wrong with EmEditor.

    Now I tried starting EE directly from Explorer, and when it runs with normal privilages, opening files from outside works correctly.

    Sorry for the false alarm.

    #9638

    Yutaka Emura
    Keymaster

    Hi Flint,

    Thanks for finding the cause of this. Nevertheless, this is still a potential bug, so I am fixing this. When the previous EmEditor window was launched as an administrator, the next EmEditor should open the file separately.

    Thank you!

    #9640

    Kalum
    Member

    Hello, Yutaka

    What is Unicode Ideographic Variation Sequence (IVS)?

    Is this related to the issue I’ve posted before in below topic?

    http://www.emeditor.com/modules/newbb/viewtopic.php?topic_id=1773&forum=12

    I’ve tested this version, and have found that when reading Thai language, this version is displaying correctly. But when I type Thai language in this version the, previous issue still remain.

    Thank you.

    #9641

    Yutaka Emura
    Keymaster

    The issue you posted was not related to the IVS.

    I have seen your screencast, but it was hard for me to reproduce the issue.
    Can you explain which key you have to press to reproduce this issue using the Thai keyboard, or may be EmEditor’s Insert Special Character command. I am using English keyboards, and I don’t know which key sequence do I have to press in Thai keyboard, or which Unicode characters I have to enter.

    Thanks for your patience.

    #9642

    Yutaka Emura
    Keymaster

    Hi Kalum,

    I believe I fixed this issue on RC 2.

    Thank you!

    #9685

    Kalum
    Member

    Hello Yutaka,

    I’ve tested on v11.0 posted on the download page (Final Version)

    Thai language typing issue I’ve mentioned before now work perfectly as it should be.

    Thank you for your kind support in development 🙂

    Best Regards,

    Kalum K.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone