Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25874

    LTT
    Participant

    1:
    Filter toolbar:
    When the “Whole Line” box (or either of the two “Number of Lines” boxes) is focused,
    Press Esc key.
    ** The filtering will be aborted.

    2:
    Filter toolbar:
    Disable “Incremental Search”.
    Press Up/Down key in the Filter box.
    ** The behavior (in the drop-down list) is weird.

    3:
    Find toolbar/dialog:
    Enable “Incremental Search”.
    Press Up/Down key in the Find box.
    The behavior is not like in Filter toolbar.
    Which is as expected?

    #25891

    Yutaka Emura
    Keymaster

    1. This is actually an intended behavior. Some customer asked us to add this behavior so that they can easily toggle on and off the filter.

    2. and 3. will be fixed on the next version.

    Thank you,

    #25906

    LTT
    Participant

    3+:
    Find toolbar:
    Enable “Incremental Search”.
    Press Up/Down key in the Find box. (e.g. 111 ↓ 222 ↓ 333 ↑ 222 ↑ 111 )
    ** The selection and color changing in the document shows that the incremental search lags one step. ( 111 → 111 → 222 → 333 → 222 )

    So the Find dialog box will not have this behavior?

    —————
    4:
    The history Search Colors (i.e. from Search string (2) ) is temporarily suppressed during incremental search.
    ** But once I press Enter key, or Find Previous/Next is used, the history Search Colors should work again.

    #25925

    LTT
    Participant

    5:
    Find toolbar:
    Enable “Incremental Search”.
    Press Up/Down key in the Find box.
    While the list is open, press Win key (or any way to take the focus from EmEditor).
    ** The search will be triggered.

    #25928

    LTT
    Participant

    5+:
    This also occurs when Incremental is disabled.

    The difference is:
    When Incremental, it will be trigged twice. (See the selection moving.)

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.