Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #10422

    Deipotent
    Participant

    Is there an option to stop the word under the cursor being used as the Find text when the Find dialog is invoked ?

    I would like an option to only use selected text as Find text, and if nothing is selected, use the previous Find text.

    Also, with the Find/Replace In Files dialog, there is a problem with the File Types edit box when Use Output Bar is disabled…

    If I have a Find mask of “*.c” and do a Find/Replace, then open Find In Files again, append “;*.h” to it (ie. so it becomes “*.c;*.h”) and do another search, when I open Find In Files again, the mask will be set to “*.h” rather than “*.c;*.h”. It seems to set it to the last mask (eg. if it was “*.a;*.b;*.c;*.d”, it will be set to “*.d” the next time). It should keep the previous mask.

    NOTE: This only happens with Use Output Bar disabled.

    One last problem:

    The In Folder control seems to track which file is currently being viewed, and sets it to the same folder the next time you do Find/Replace In Files. Can you add an option to disable this tracking, so it always just uses the previous path.

    #10430

    Yutaka Emura
    Keymaster

    Hello!

    Please go to the Find dialog, click “>” button next to the Find text box, and a menu appears. Please select the “Custom”, then click the “>” button again and select “Save as Default”. This way, next time, it shouldn’t change the initial text that appear in the Find text box.

    Likewise, you can do the same way with the File Types drop-down list box, and the Folder drop-down list box — select the “Custom” will remember the last used item.

    Thanks!

    #10431

    Deipotent
    Participant

    Doh! I had seen those options before, but didn’t check. 😳

    #10438

    Deipotent
    Participant

    There appears to be a bug with Find/Replace In Files where the Find is always set to Selected Text, even after you change it and save as default.

    #10444

    Yutaka Emura
    Keymaster

    Hello,

    I reproduced this issue, and will fix the issue soon.
    Thank you!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone