Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7775

    netsking
    Participant

    Hi, there,
    I have met a strange thing when I saved my text file.
    Each time, when I saved my text file, the curse moved to the end of the file, and added another n in the end of the line.

    Does anybody know what cause this problem or how to fix this? Thank you in advance.

    #7785

    Yutaka Emura
    Keymaster

    netsking wrote:
    Hi, there,
    I have met a strange thing when I saved my text file.
    Each time, when I saved my text file, the curse moved to the end of the file, and added another n in the end of the line.

    Does anybody know what cause this problem or how to fix this? Thank you in advance.

    Please make sure:

    Configuration Properties > File tab > Saving… button > Insert Returns when Saving

    is not checked.

    #7791

    netsking
    Participant

    I did not check the function as you mentioned. But the problem is still.

    #7792

    Yutaka Emura
    Keymaster

    netsking wrote:
    I did not check the function as you mentioned. But the problem is still.

    Do you use any plug-ins? You might want to try disabling all plug-ins. Also, if you set any macros for any events, you might want to disable all the macros at events. Event macros can be configured in the Macros menu > Customize.

    If you still can’t figure out, you might want to uninstall EmEditor, and during uninstall, select No when asked to save your personal settings. Then install EmEditor again for fresh install.

    #7804

    netsking
    Participant

    It’s caused by plug-in. I did not know which one yet.
    Usually, I install everything by default.
    Right now, I found it was caused by the plug-in
    Whitespace plug-in.

    #7809

    netsking
    Participant

    FIY: updated
    If you check “ensure final line-end on save” in whitespace plug-in,
    when you save you file each time, a n will add at the end.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone