Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #9099

    shx
    Participant

    In terms of highlighting

    strings enclosed by quotation marks takes precedence over highlighted words.
    So if a highlighted words is surrounded by quotes it will loose the look of a highlighted word.

    Is there anyway to keep the highlighted words even if they are surrounded by quotes?

    thanks

    Steven

    #9100

    Yutaka Emura
    Keymaster

    Steven,

    The only way I can think of is to disable the highlight of quoted strings.

    Thanks,

    #9101

    CrashNBurn
    Member

    I would think a custom field, for blocking quote hilighting might work.

    Don’t consider quotes a string (when matches):
    [ ]?style=”.*”

    [x]Regex

    Otherwise you have to disable quote hilighting.

    There’s also a bit of a bug in that regard, when you have a custom highlighter and do something like:
    RegExMatch(Foo, “”test””)

    EmEditor thinks “” is the start and end of a string, and “” is the start/end of a string.

    Possibly, as well:

    Ignore Escaped quotes:

    #9102

    shx
    Participant

    The only way I can think of is to disable the highlight of quoted strings

    How ?

    #9103

    shx
    Participant

    Never mind, i see how to disable it.

    CrashNburn,
    thanks for your reply.

    Can you explain what you mean, i am not sure .

    What i did was disable quotes and added 2 highlighted regex words
    “.+?”

    ".+?"

    and then the other one I am working with.

    this worked because it seems that it uses the later word to to override the earlier highlight word.

    #9106

    CrashNBurn
    Member

    I was talking about possible new features,
    1) Allow a custom regex to be used to indicate when “” quote string hilighting shouldn’t be done.

    2) Allow a custom input field for notifying EmEditor what leading characters before a quotation-mark should indicate that the quotation-mark is part of a string (is escaped).
    e.g, RegexMatch(Foo, “This is a “string” that has embedded quotes. The string hilighter shouldn’t end after ‘This is a’ as the quote is escaped.”)

    Currently EmEditor only allows you to list a single character as an escape for a string (quote). In autohotkey for instance, I would need two. ` and

    #9109

    shx
    Participant

    O.K. CrashNBurn.

    Thanks for your help

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.