Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #10813

    ArthurZ
    Participant

    I think this is a core defect:

    Create a new macro (in my case made it swap-lines).

    Assign a keyboard shortcut. Place it onto the Macros toolbar.

    Use the new shortcut. Exit EmEditor.

    Come back to change the shortcut; Restart EmEditor. The old shortcut sticks to the tooltip and the only one that works. Not the new shortcut. Further replacements of the key combinations have no effect.

    Supporting images:

    #10814

    JohnQSmith
    Participant

    I’m not sure you can use Shift+S as a keystroke.
    I mean… Shift+S is Uppercase-S.

    Then again, it may be a problem in that you confused it.

    #10816

    Yutaka Emura
    Keymaster

    Hello,

    I couldn’t reproduce the issue, but I believe there is a bug. I just can’t reproduce the same procedure or conditions that you have.

    However, you can try this if something is not synchronized on the Macros toolbar: Please right-click on the Macros toolbar, and select “Refresh”.

    Thanks!

    #10817

    ArthurZ
    Participant

    Silly on my side to assign Shift-S, true, but it is not to deceive me. It is just a test that ended badly 🙁 .

    Yet, the key combination must not be important John.

    So no mistake on my side, the keyboard command assigned must adhere to the configuration setting.

    Therefore this is a bug.

    #10818

    ArthurZ
    Participant

    Thank you Yutaka for the attempt to recover, unfortunately the refresh does not help.
    On the bright side, I now know why this option is there :-).

    Now, since me, silly, assigned Shift-S to the swap lines, and I cannot un-do this assignment I am stuck being unable to type capital Ss 🙁

    I am at despair, please tell me there is one more trick before the complete removal . 😮

    #10819

    Yutaka Emura
    Keymaster

    Hello,

    Can you try both “Properties for Current Configuration” and “Properties for All Configurations” to remove the SHIFT + S shortcut from your macro? You can also press “Reset” on “Properties for All Configurations” to completely reset shortcuts although you might not want to reset all.

    Thanks!

    #10822

    ArthurZ
    Participant

    Ahh it WAS a sticky situation!

    I did replace the keyboard keys to new ones in both configs to https://i.imgur.com/OX0kcVJ.png, didn’t help.

    I then reset all, and it did remove all my keyboard shortcuts I put in place, but Shift-S was still alive and working, the refresh does not help either.

    But the moment of rejoice has come after I exited and restarted the editor, now the old keyboard key assignment has finally gone.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone