Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #5606

    Dadooda
    Member

    Hi.

    Is it possible to change the default behaviour of Next/Previous Document function (Ctrl-Tab/Ctrl-Shift-Tab or Ctrl-F6/Ctrl-Shift-F6) to STRAIGHT left-to-right/right-to-left switching of open document tabs?

    I’d like tab switching work in STRAIGHT order. Let me explain. Suppose I’ve opened three documents – 1.txt, 2.txt and 3.txt. Active document is 1.txt. Pressing Ctrl-Tab twice will bring me back to 1.txt, which I’m totally unhappy with and I’d expect it to be 3.txt, which is 2 steps from 1.txt.

    I’d like straight order of tab switching since default behaviour makes it virtually impossible to switch (using keyboard) between 3 or more open documents. Therefore, one has to use a mouse just for switching the tabs! That’s not a good feature for an established professional development tool, which EmEditor certainly is.

    I’m using EmEditor Professional version 7.00.1 under Vista…

    #5607

    Yutaka Emura
    Keymaster

    Dadooda wrote:
    Hi.

    Is it possible to change the default behaviour of Next/Previous Document function (Ctrl-Tab/Ctrl-Shift-Tab or Ctrl-F6/Ctrl-Shift-F6) to STRAIGHT left-to-right/right-to-left switching of open document tabs?

    I’d like tab switching work in STRAIGHT order. Let me explain. Suppose I’ve opened three documents – 1.txt, 2.txt and 3.txt. Active document is 1.txt. Pressing Ctrl-Tab twice will bring me back to 1.txt, which I’m totally unhappy with and I’d expect it to be 3.txt, which is 2 steps from 1.txt.

    I’d like straight order of tab switching since default behaviour makes it virtually impossible to switch (using keyboard) between 3 or more open documents. Therefore, one has to use a mouse just for switching the tabs! That’s not a good feature for an established professional development tool, which EmEditor certainly is.

    I’m using EmEditor Professional version 7.00.1 under Vista…

    Go to Customize on the Tools menu, click Window tab, and uncheck “Switch to Last Used Document for Next Document Command”.

    #5608

    Dadooda
    Member

    Thank you, Yutaka!

    Now I’m a happy man again. 😀

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone