Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #22122

    sky
    Participant

    Fresh EmEditor 17.0.0 & 17.0.1 portable, 100000 lines of “0123456789”, Display Matched Strings Only.

    Output Bar is not selected first.
    1. Extract “1” without Regexp -> 0.063 sec, OK
    2. Extract “\d” with Regexp -> 0.547 sec, OK

    Check the Output Bar check box.
    3. Extract “1” without Regexp -> 0.703 sec, OK, click “X” to close Output Bar.
    4. Extract “\d” with Regexp -> 8.250 sec, OK
    5. Close EmEditor and launch EmEditor

    Output Bar is still selected.
    6. Extract “\d” with Regexp -> 8.188 sec, OK, click “X” to close Output Bar.

    Uncheck the Output Bar check box.
    7. Extract “1” without Regexp -> 53.656 sec, speed is very slow, and also impact to EmEditor other operation.
    8. Extract “\d” with Regexp -> 53.672 sec, speed is very slow, and also impact to EmEditor other operation
    9. Close EmEditor(very slow) and launch EmEditor

    Check the Output Bar check box.
    10. Extract “1” without Regexp -> 0.703 sec, OK, click “X” to close Output Bar

    Uncheck the Output Bar check box.
    11. Extract “1” without Regexp -> 5.344 sec, speed is also slower than normal.
    12. Extract “\d” with Regexp -> 5.422 sec, speed is also slower than normal.
    13. Close EmEditor(slower than normal)

    #22195

    Yutaka Emura
    Keymaster

    Hello sky,

    I am having a difficult time to reproduce the issue. Can you still reproduce the issue with the most recent beta version?

    If so, please let me know which options are enabled in the Find dialog box, and also click the Advanced button in the Find dialog, and let me know all the options, regex engine and the number of lines in the Advanced dialog box, as well as all the options in the Extract options.

    Thanks,

    #22199

    sky
    Participant

    It still can reproduce the issue on v17.1.0 beta 4.

    Step 1. Fresh EmEditor v17.1.0 beta 4, initial launch and open a file with 100000 lines of “0123456789”.
    1

    Step 2. Extract “\d” with Regexp -> 0.547 sec, OK
    2

    Step 3. Check the Output Bar check box, and then Extract “\d” with Regexp -> 7.703 sec, OK
    3

    Step 4. Uncheck the Output Bar check box, and then Extract “\d” with Regexp -> 54.9 sec, speed is very slow than step 2.
    4

    #22206

    Yutaka Emura
    Keymaster

    Hello,

    I reproduced the issue now.

    This is because the Output Window contains many lines of text even if you close the Output Window.
    You will probably experience the same slow behavior if you try to create a new file (CTRL+N) or open a new file after Step 3.
    I will address this issue, but you might want to clear the contents of the Output window (by selecting Clear All on right-click menu in the Output Window) before you close it to minimize this issue.

    Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone