Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #17359

    atnak
    Participant

    Steps to reproduce:
    1. Start with a file whose EOL is “LF Only (UNIX)”
    2. Perform Ctrl-A followed by Ctrl-V

    Unexpected result:
    * EOL becomes “CR+LF (Windows)”

    Expected result:
    * EOL stays “LF Only (UNIX)”

    #17360

    Stefan
    Participant

    Hi atnak.

    I don’t know details, but perhaps check out if this help entry will solve your issue:

    EmEditor Help – Dialog Boxes – Configuration Properties > General tab

    Preserve (CR/LF) returns on Clipboard check box
    If this box is checked, the return methods will be preserved at copy and paste.
    For instance, the LF only returns will be copied and pasted to another location with LF only returns.

    .

    #17361

    atnak
    Participant

    Preserve (CR/LF) returns on Clipboard check box

    Thanks for the advice. However, I don’t think this helps.

    #17362

    atnak
    Participant

    Alternate steps to clarify the problem:
    1. “Tools > Customize… > Status > Return Method” should be checked
    2. Create a new document and type “a<Enter>b”
    3. Save the document, selecting “LF Only (UNIX)” as the Return Method in the Save dialog.
    4. Notice the Status Bar shows “LF Only (UNIX)”
    5. Ctrl-A to Select All, then type “c” (or alternatively, hit Ctrl-C to Copy followed by Ctrl-V to Paste)
    6. Notice the Status bar now shows “CR+LF (Windows)” <– Problem here

    #17363

    Stefan
    Participant

    .

    5. Ctrl-A to Select All, then type “c”
    6. Notice the Status bar now shows “CR+LF (Windows)” <– Problem here

    The Status bar now shows “CR+LF (Windows)” .
    For me only if working on the first line.
    And only until I press Enter one time after the ‘c’, then it switch to “LF Only (UNIX)”

    Tested with 13.0.5 portable.

    The “Tools > Customize… > Status > Return Method” has nothing to do with this situation at all as it seems.

    Maybe I just don’t get it right. Please wait for Yutaka.

    .

    #17364

    atnak
    Participant

    And only until I press Enter one time after the ‘c’, then it switch to “LF Only (UNIX)”

    Oops, an amendment: You need to close & reopen the document between steps 3 and 4. Then, it’s not temporary.

    The “Tools > Customize… > Status > Return Method” has nothing to do with this situation at all as it seems.

    It has nothing to do with the cause. But you’ll be hard pressed to see the problem if you can’t see what the Return Method is in the status bar.

    #17369

    Yutaka Emura
    Keymaster

    Hello atnak,

    Please go to Configuration Properties, File tab, New Files button, and select “LF Only (UNIX)” from the Return Method. This should resolve the issue.

    Thanks!

    #17370

    atnak
    Participant

    Please go to Configuration Properties, File tab, New Files button, and select “LF Only (UNIX)” from the Return Method.

    Strange, I can’t get this to resolve the issue.

    I’m using “EmEditor Professional (64-bit) Version 13.0.6” and my system’s default encoding is “日本語 (シフトJIS)”.

    Properties for Current Configuration (txt) shows:

    • New Files… > Return Method: LF Only (UNIX)
    • Saving… > Return Method: No Change

    My test file is “Untitled.txt” (Return Method = LF Only (UNIX)) containing:

    a
    b
    c

    Important: EmEditor should be closed once after creating this file before attempting to reproduce.

    To reproduce, I simply open “Untitled.txt” from Explorer, check that the status bar shows “LF Only (UNIX)”, then hold down Ctrl and type A, C, V.

    #17382

    Yutaka Emura
    Keymaster

    Hi atnak,

    I reproduce the issue if the “Preserve (CR/LF) returns on Clipboard” check box on the General tab of configuratoin properties is not checked. However, I think newlines should always be LF even if this checkbox is not set. I will look into this issue.

    Thanks!
    Yutaka

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.