Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #8261

    Meir
    Participant

    Dear Yukata,

    Regarding Spell Checking:

    1) One can select rather nicely where spelling errors are detected and marked (Tools -> Properties for… -> Spelling). However, when the toolbar button is clicked, all these selections are ignored and the speller starts from the beginning.

    2) It would be nice if the “Add to Dictionary”, the “Ignore”, the “Ignore All” and the list of suggestions could be added to the context (right click) menu. A good example is the Firefox speller.

    Regards
    Meir

    #8267

    Yutaka Emura
    Keymaster

    Hello mguttman,

    Thank you for using EmEditor!

    Which toolbar button are you talking about? There are no spelling checker buttons yet in the current version (beta 6). I suppose you are using a Plug-in spelling checker. The plug-in spelling checker is completely different from the new spelling checker. So you should uninstall the old plug-in spelling checker.

    “Add to Dictionary” command is already included in the context menu. “Ignore” and “Ignore All” are not (same as FireFox). I might consider those Ignore commands in future versions.

    Please let me know if you have further questions.
    Thanks again!

    #8274

    Meir
    Participant

    Dear Yutaka,

    Well, I have now the Beta 4 version, so I’ll upgrade to Beta 6 and retest.

    As for the button: it is there in Beta 4. In fact, it was the default. I didn’t customized it to be there. I did a window snapshot with it, but I don’t have a site to post it to and provide its URL. Is there a way to post it otherwise?

    Regarding the Context Menu: you are right, FF does only features the “Add to Dictionary” and suggested replacements. But, as a user of MS Word where “Ignore all” is there, I can testify that this is very helpful. Sometimes you are dealing with an esoteric and temporary issue. If you don’t want to burden your dictionary with all these short-lived terms, “Ignore all” is very handy.

    For your consideration,

    Regards,
    Meir

    #8280

    Yutaka Emura
    Keymaster

    You can email your screenshots to me at tech@emurasoft.com, and please identify yourself and mention your user name (mguttman).

    I will consider “Ignore All” command in future versions.

    Thank you,

    #8287

    Meir
    Participant

    Dear Yutaka

    I just upgraded to Version 10 Beta 6. The button I was talking about is there too, by default, see circled:

    Once you click it, this screen pops up:

    And another Speller issue:

    By default, the context menu provides neither the “Word suggestions” nor the “Add to dictionary” menu items. So I invoked the “Customize Menus” tool:

    There, as you can see, I added the “Spelling suggestion”. But, two problems:

    1. I couldn’t find the “Add to Dictionary” menu item to add it.
    2. Even though I added the “Spelling Suggestion” item, the context, pop-up menu always showed “No Spelling suggestion”. You can see the wiggly spelling error line in the first screen shot as a sign that I activated the speller. Also, I tried just clicking the right mouse button over the erroneous word and I tried to do so after I selected it, but in either case only “No spelling suggestions” showed. (I cannot attach a screen-shot since the pop-up context menu is erased as soon as I hit the ALT key to do the ALT-PRNT SCRN.)

    What did I do wrong???

    Regards
    Meir

    #8289

    Yutaka Emura
    Keymaster

    Hello mguttman,

    I received your email. Thanks for your screenshots Apparently, you are using the U.S. Spelling plug-in. The toolbar button is in the plug-ins bar. This should be uninstalled. To uninstall the plug-in, you can go to Tools menu, Plug-ins sub menu, and then select the Spelling (U.S.), and click Uninstall button.

    The context menu should be populated with suggested words when you right cilck on a word underlined with a red wiggly line. “Add Dictionary” will be right after all the suggested words. When you define menus, “Add Dictionary” can’t be selected, but it is included in “Spelling Suggestions” command.

    I hope you understand all the above. Please let me know if you still have questions.
    Thank you for using EmEditor!

    #8292

    Meir
    Participant

    Thanks Yutaka!

    The US Spelling plug-in came bundled with your Win32 Beta 6 (and 4 before it.) I didn’t install it myself, separately.

    And yes, I tried to see suggested words/”add to dictionary” when I indeed was on a wiggly underlined word, but to no avail…

    OK! So assuming I uninstall the US speller plug-in. What speller plug-in should I install instead?

    Regards,
    Meir

    #8299

    Yutaka Emura
    Keymaster

    Hello mguttman,

    Please make sure a proper language is selected from “Dictionaries” popup menu (on the context menu). Please try another word if you can see any suggestions and “Add to Dictionary” command. No plug-in is necessary.

    #8301

    Meir
    Participant

    Hi Yutaka!

    I did what you said: I uninstalled the language plug-in, a dictionary is selected, I manually configured (is that the problem?) the Pop-up Context menu to include “Spelling suggestions”, I am clicking the RMB over an erroneous word, but nevertheless the context menu shows a PARENTHESIZED GRAYED-OUT “(No Spelling Suggestions)”.

    Well, where did I go wrong?

    Regards
    Meir

    #8302

    Yutaka Emura
    Keymaster

    Hello mguttman,

    Can you try resetting the Context Menu? To do that, select Customize Menus on the Tools menu, select “Context Menu”, and then click “Reset”. I hope this helps this time.

    Please let me know if you still have issues.

    #8305

    Meir
    Participant

    Sorry Yutaka, I did as you instructed but it is still the same: a grayed-out “(No Spelling Suggestions)”.

    BTW, a reset sets the first context menu item to just that, a parenthesized “No Spelling Suggestions”.

    Sigh…

    Meir 😡

    #8335

    Meir
    Participant

    Dear Yutaka!

    I installed EmEditor as an Administrator (obviously) but I immediately switched to my working user account. Only There I configured it to my liking, mostly display and keyboard shortcuts. The Admin account however remained in its mint default condition.

    So I had an idea: I’ll switch to the Admin account and see how is the speller doing there. And voila, there, not only were “word suggestions” and “Add to Dictionary” alive and kicking, the out-flier when clicking the bottom context menu, “Dictionaries >” was grays-out, namely as though no dictionaries are installed. As opposed to this, in my working account, an active “1 en_US” is shown!

    So I came back to my work account and tried to switch back to the mint default condition, as in my Admin account. I clicked many “Reset” buttons in many tabs of the “Properties of ALL configurations” menu item, but no improvement!

    How can I reset all settings to the default, clean installation state?

    Regards,
    Meir

    #8337

    Yutaka Emura
    Keymaster

    Hello mguttman,

    If you uninstall EmEditor, and click “No” when you are asked to save your data during uninstall, and install EmEditor again, then all your data will be fresh.

    I don’t know why you had so many problems with spelling features, but I hope you can figure out what the problems were. Please let me know if you still have questions.

    Thank you,

    #8340

    Meir
    Participant

    Dear Yukata,

    I think I caught the culprit!

    As you suggested, I uninstalled EmEditor and answered “No” to the proposal to keep the settings. On reinstall however, the speller behavior was the same. I then went on and with the RegEdit expunged all traces to the EmEditor from the registry. I also deleted all related files.

    Such a clean reinstall seemed to do the trick. All these speller features were there: Suggested spelling alternatives, “Ignore all” (Thank you Yukata!) and “Add to dictionary”. Wonderful!

    I then went on with (misplaced as it turn out) confidence to configure where spelling is checked. As a software developer (and a non-native English speaker) I need the speller to check just comment text where I use “natural” (as opposed to “computer”) language. Well, when I did that, all speller features disappeared! Oh God, not again!

    I experimented a little, and my conclusions are:
    * Checking only “Comments” turns off the features
    * Checking say “Strings Enclosed by Single (Double) Quotation Marks” will turn on the spelling features only when right clicking over misspelled single (double) quotation marks, but NOT when right clicking a misspelled comment text, even when the “Comments” check-box is checked (!)
    * However, checking both the “Comments” and the “Rest” check-boxes did turns on the spelling features on right clicking misspelled comment text (?)

    Please make it possible to have a full featured speller on comments only…

    Regards,
    Meir

    #8346

    Yutaka Emura
    Keymaster

    Hello mguttman

    Thanks for reproducing this bug, and I am very sorry for any inconveniences. I am fixing that bug on the beta 10.

    If you have further questions, please let me know.

    Thanks again!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone