Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11101

    urlwolf
    Member

    … There’s fortran, but no coffeescript, no clojure,…
    In 2013. This cannot be :)

    #11102

    urlwolf
    Member

    And this is beyond archaic:

    How can I install an EmEditor syntax file? 1. Choose Select Configuration under the Tools menu. 2. Click Define Configuration at the very bottom of the list. 3. Click the New button, select Use Default Configuration and click OK. 4. Enter a descriptive name and click Enter. 5. Click the Properties button and select the Highlight (1) tab. 6. Click on the Import button, locate, and open the appropriate syntax file. 7. Finally, click on OK to close the Properties dialog box and click on Close to close the Configurations dialog box. If you want to enable associated extensions and specify an extension or extensions that EmEditor should associate with the configuration, follow these additional steps: 8. Make sure the correct configuration is selected under the Tools menu. 9. Click Properties for Current Configuration under the Tools menu. 10. Select the Association tab and check the Enable Association box. 11. Click Add and enter the appropriate extension or extensions.

    11 steps, requiring me to move files around (this won’t survive reinstalls or work when I export my settings)…

    Nobody is doing 11 steps when in other editors it either comes by default, or it takes a click or two.

    If I were the author, I’d drop everything and modernize the ‘add syntax’ feature. It’s probably the worst implementation on any editor, in any platform.

    #11103

    urlwolf
    Member

    Once I add a configuration, it uses the default font, not the one I specified in my ‘all configurations’ font settings.

    Can this process be any more unwelcoming? I really wonder…
    Sorry about the harsh criticism, but this is one aspect where em is far behind. Overall an excellent editor, with features not available in Linux/OSX editors and very envy-worthy!

    #11104

    urlwolf
    Member

    Oh, it gets better…
    It forget my wrap settings.

    Bah!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.