Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #24071

    LTT
    Participant

    Tab characters are invisible (0-width) in any non-TSV mode.

    #24074

    Yutaka Emura
    Keymaster

    Can you check View -> Marks -> Tabs? Are they still invisible?

    #24078

    LTT
    Participant

    In a non-TSV mode (eg. CSV, DSV, |-SV, …),
    “x(one or more Tabs)x” is displayed as “xx”, as if no character were there.

    #24185

    LTT
    Participant

    Can you reproduce this?
    I don’t think this is a proper behavior.

    #24187

    Yutaka Emura
    Keymaster

    No, it should be seen as “x x”. There should be a single-character-width gap between “x” and “x”.

    #24188

    LTT
    Participant

    I checked it again and think you are using DirectWrite.

    #24189

    Yutaka Emura
    Keymaster

    No, I am not using DirectWrite. Which font are you using? Can you try another font?

    #24192

    LTT
    Participant

    I tried some and think no font can avoid it here.

    And with default settings in portable version, I tried all the default font categories.
    Only the initial “OEM/DOS” shows a gap (but with a dot), which looks odd (see the left image), though by opening its font I see “Consolas”. If I click OK in Font dialog, then it shows the normal “Consolas” (same as “Western European” in the right image). So it seems the initial “OEM/DOS” category has another certain issue.
    null

    #24193

    Yutaka Emura
    Keymaster

    I reproduced the issue with Chinese system locale on Windows 7. I will look into the issue.
    Thanks,

    #25430

    LTT
    Participant

    New issue:
    See the image:
    null
    Non-TSV (e.g. CSV) mode.
    There are 10 tabs in line 1.
    ** But only 4 arrows can be seen.
    ** And they are different in width.

    #25449

    Yutaka Emura
    Keymaster

    Hello LTT,
    This issue will be fixed on v18.6.5.
    Thanks,

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.