Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #10478

    Bill_Stewart
    Participant

    Goal: Only auto-indent when line above contains at least one non-whitespace character.

    Fresh install of 11.0.5

    Copy ‘Pascal’ configuration (makes ‘Pascal2’)

    Select new ‘Pascal2’ configuration

    Go to Tools->Properties for Current Configuration->General tab, click Tab/Indent button

    Use following settings:

    * Enable Auto Indent
    * Use Regular Expressions
    * Tab columns: 4
    * Indent columns: 4

    Begin Indent: (empty field)
    End Indent: (empty field)
    End of Statement: (empty field)
    Ignore After (Regular Expression): ^s*$

    This does not work as I expected: If I press Enter and line above is empty or has only whitespace, I get an indent.

    If I uncheck the “Use Regular Expressions” option, it then works as I expected: Indent is only inserted if previous line contains at least one non-whitespace character.

    Question: Is this the expected behavior, or am I not understanding these options correctly?

    Thanks

    Bill

    #10479

    Yutaka Emura
    Keymaster

    Hello,

    Can you please try the latest beta version at http://www.emeditor.com/modules/newbb/viewforum.php?forum=12 and see if you can reproduce the issue?

    If you can reproduce the issue, I would appreciate if you can explain the details how I could reproduce the issue.

    Thank you!

    #10481

    Bill_Stewart
    Participant

    Hi Yutaka,

    I downloaded latest 11.1.9 beta 32-bit portable and the problem is exactly the same: Uncheck “Use regular expressions”, and “ignore after” works. Check it again, and “ignore after” does not work.

    To reproduce, follow exact steps at beginning of thread.

    Thanks!

    Bill

    #10482

    Yutaka Emura
    Keymaster

    Hello,

    I reproduced this issue, and I now understand. I fixed the issue on v11.1.10. I apologize not trying to reproduce the issue earlier.

    Thank you!

    #10483

    Bill_Stewart
    Participant

    Thanks!

    Bill

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone