Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20839

    CaptainFlint
    Participant

    I have a text file of about 400 lines, 20 Kb size. I try to perform Replace All with the following regexp:
    ^(?!http).*\n
    Replacement is empty string. Before I updated to 15.9.0 it always worked fine (I need to do this regularly). Now, however, it displays:

    Undo will not be available because the available memory is low or the Undo data size is too large. Are you sure you want to continue?

    At the moment I have over 7,5 Gb free memory (2 Gb of it is free physical RAM). How on Earth could that be “low memory” for undoing 20 Kb of text?!

    #20840

    jic
    Participant

    FYI:
    I’ve replicated this problem also. Worked fine in 15.8.x, and after updating to 15.9.0, it brings that prompt. In the New Features of the new 15.9.0, it states,

    The settings for Undo buffer is obsolete. Instead, the physical memory size is used to determine whether the Undo should be retained. The physical memory threashold can be set in the Advanced tab of the Customize dialog box.

    which may be related. I tried other regexp searches and replaces, and these worked fine.

    #20841

    Yutaka Emura
    Keymaster

    I couldn’t reproduce the issue here. Can you email me a sample file that I can reproduce the issue? (tech @ emurasoft.com)

    Can you check the Maximum Memory Size in the Advanced tab of the Customize dialog box? The default value is 80%. You can also check the “Percentage of Physical Memory in Use” in the Status tab of the Customize dialog box. This “Undo will not be available…” message appears when the percentage of physical memory in use exceeds the specified percentage (80% by default).

    If the message appears because the memory is actually low, you can set the “Prompt when No Undo Information is Available” or “Always Discard Lengthy Undo Information to Accelerate” check box in the Edit tab of the Customize dialog box.

    Thanks,

    #20844

    CaptainFlint
    Participant

    Ah, thanks for the explanation, I know the reason then. I have 16 Gb of RAM, so EE expects that 20% (which is 3,2 Gb) should be free, and 2 Gb are less than 3,2. I think this scheme should be improved somehow. Maybe take into account the size of the currently edited file, because, obviously, memory requirements for 20 Kb file and 100 Mb file would be different.

    In general, I must say, the description of the new Undo behavior is quite confusing. I simply did not understood how all this worked, until you described it now. And description of the options in the help is not of much use either:

    Maximum Memory Size text box
    Specifies the maximum memory size used in percentage.

    #20846

    Yutaka Emura
    Keymaster

    Hello,

    I changed the default value to 90%, and will clarify the Help.

    Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.