Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #11166

    Kalum
    Member

    Hello Yutaka,

    I’ve found the error for Version 13.0.1 (on Windows 7 and 8) about Thai character spacing.

    Please see the word กำไร (U+0E01 U+0E33 U+0E44 U+0E23). This word means “Profit” in Thai.

    You will see this word shown correctly in browser / word processor, but not for EmEditor which showed a space after U+0E33 (Sara Am) character. It shouldn’t have a space after this character.

    Sara Am character.
    http://www.decodeunicode.org/u+0E33

    I believed that the problem occured in V 12.0 as well.

    #11170

    thanksgod
    Participant

    Yes I’ve been experienced this problem since v12.0 and ONLY in WIN7 & WIN8 (winXP is working fine). And just like the OP said, in other word/text processors are working CORRECTLY, except EmEditor.

    haha I thought I’m the only user that encounter with this “THAI” language problem.

    FYI, for me it’s not just only for Sara Am, but it’s working INCORRECTLY for all “THAI” fonts as far as I’ve tried.

    Actually, I should report this since the release of v12.0 already, but I thought it’s just only me who faced this problem and I believed it was because of my windows had problem. Now, when there is some people got the similar issue as mine, so now I’m quite sure that there must be something wrong with the Emeditor.

    Hope you can fix and release the minor version very soon.

    Thank you so much Yukata!!

    #11171

    Yutaka Emura
    Keymaster

    Hello,

    Can you try settings the UseUniscribe value in the Registry as below? You can also try changing the UseWidthArray value:

    HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common

    UseUniscribe DWORD default: 1 for Windows XP, 0 for Windows Vista or later

    UseWidthArray DWORD default: 1

    Thank you,

    #11172

    Meir
    Participant

    Dear Kalum,

    Just out of curiosity, is Thai written left-to-right or right-to-left? (I am asking, since my language is Hebrew, which is written, like all native middle-eastern scripts, RTL. And I am also experiencing bad display of Hebrew.

    #11177

    thanksgod
    Participant

    Hi, mguttman
    Sorry, if I answer instead of the OP, as I’m using Thai language too. OK, Thai language is written left-to-right just like the English language.

    However, there is some character that need to be written “above” and “under” another character, which does Emeditor to make the “unintentional whitespace” between those characters just like the picture that OP has shown above.

    Hi, Yukata

    Thanks for the advice, Yukata.
    BTW, I have put those 2 DWORDs values as you suggested but still doesn’t work. Is there any other solutions please?

    Cheers!!

    #11178

    Yutaka Emura
    Keymaster

    Hello,

    Did you try both 1 and 0, which makes 4 combinations in total?

    Thanks!

    #11179

    thanksgod
    Participant

    Hi, Yukata

    UseUniscribe DWORD
    UseWidthArray DWORD

    I’ve tried both 4 combinations

    UseUniscribe:UseWidthArray

    0:0
    0:1
    1:0
    1:1

    It just gives me the same result as the previous one when I haven’t had that 2 values in the registry (by DEFAULT after Fresh installation)

    Cheer!!

    #11181

    Meir
    Participant

    Dear “thanksgod”!

    Thank you!

    FYI, Hebrew also have the so called “diacritics” which are part of many scripts, even the Latin-1! The German “umlaut” ones, the french “circumflex” as well as various Polish, Turkish and many more languages.

    Hebrew in particular has many of these. My experience with previous EE versions (I didn’t upgrade to v.13 yet) tells me that it displays some right but many more not so. Even some of the European, Latin-1 diacritics are not displayed right, e.g., ĉb (small Latin ‘c’ U+0063 + Combining Circumflex Accent U+0302 and then small Latin letter ‘b’) are displayed ‘c’ and above it the Circumflex (correct!) then a space (not correct!) and then the ‘b’.

    BTW, all of it was tried using the UTF-8 encoding.

    Are you using a specialized Thai encoding (Hebrew has four, in addition to the Unicode ones), or UTF-8?

    #11182

    Yutaka Emura
    Keymaster

    Hello thanksgod,

    If you change the Registry values, you will have to restart EmEditor. In my experiments, if I set UseWidthArray as 1, the Thai character shows OK, although selecting and editing characters do not work well. On the next minor version, I handled this special character differently, so it should work better. So, please remove the UseUniscribe and UseWidthArray values before you try the next minor version. If there are any other issues with Thai, please let me know.

    Hello mguttman,

    I tried the combination of ĉb, but I didn’t see any issues. It may be because of the different OS, different version of EmEditor, or some old Registry values. What OS do you use, and which version of EmEditor do you use? If you add any Registry values, can you please remove those values?

    Thank you!

    #11184

    Meir
    Participant

    Hi Yutaka!

    OS is Win-7 Pro Version 6.1.7601 Service Pack 1 Build 7601.

    EE is Version 12.0.11 64bit

    As far as I know I didn’t change any Registry value. What should I look for?

    #11185

    Yutaka Emura
    Keymaster

    OK. This depends on fonts. Can you please try Consolas?

    Thanks!

    #11194

    thanksgod
    Participant

    Hi Yutaka!!

    Sorry for the late reply, was too busy last this week, but when I saw your reply including releasing the minor version, then I downloaded and installed, then WOW WOW WOW, it’s displaying Thai font correctly on both WinXP(as it used to), and Win 7 NOW!!!.

    btw, I should report this bug since v12.0.1 lol

    GREAT JOB, Yutaka

    Thank you so very much again!!! 😀 😀

    #11195

    Kalum
    Member

    Hello Yutaka,

    Thank you for your great update, after installing 13.0.3 the problem were gone 😀

    Now EmEditor displayed Thai Font on Windows 7 / Windows 8 correctly.

    Also thank for thanksgod, who described the problem in detail and made this fix happened 🙂

    Kalum K.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.