#11300

CaptainFlint
Participant

Somewhere in system settings, their names and locations are different in different Linux distributions.

You could try direct editing of /etc/samba/smb.conf (root permissions are required). There you find a section named like your share name (e.g. if in Windows you disk is mapped to machine_nameMyShare, then you look for the section [MyShare] in smb.conf). Within this section, if there is create mask option already, just modify its value to 0644. Otherwise append a new line with this option:

create mask = 0644

(space within “create mask” is not a typo!). Save the file and restart the Samba service. The way to do it, again, depends on your Linux system, I’d try the command

/etc/init.d/samba restart

(again, with root permissions), or simply reboot the machine.