Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #10507

    Yutaka Emura
    Keymaster

    Today, we are releasing EmEditor Professional v11.1.11 beta.

    Updates from v11.1.10 beta include:

    NEW FEATURES

    – Improved and fixed the Matching Tag Extend command (CTRL + SHIFT + .) behaviors.

    – Updated Czech (by Ivan), English (U.K.), French, German, Italian, and Spanish language files.

    – Updated English and Japanese Help files.

    BUG FIXES

    – Fixed the bug where highlighting mathing tag did not work on a certain condition on v11.1.10.

    Please see the new feature page at:
    http://www.emeditor.com/modules/feature1/rewrite/tc_40.html

    === To Download ===

    If you are already using v11.1.x beta, you can Check for Updates on the Help menu to download the update. If you are still using the released version, this new beta version will not be checked automatically from the EmEditor update checker. However, once you install this beta version, new future beta versions will be checked automatically.

    Please click one of the links below to download:

    http://www.emeditor.com/pub/emed32_11.1.11_beta.exe (32-bit installer)
    http://www.emeditor.com/pub/emed64_11.1.11_beta.exe (64-bit installer)
    http://www.emeditor.com/pub/emed32_11.1.11_beta_portable.zip (32-bit portable)

    The portable version runs more slowly than the one using the Registry, and some features including the update checker are disable for the portable version. We recommend the installers, and not the portable version.

    The portable version can be created by installing using the installer, and selecting “Import and Export” on the “Tools” menu, and “Set up a removable drive such as a USB drive with default settings”.

    Notes:

    Only English (U.S.), English (U.K.), Japanese, Korean, Czech, French, German, Italian, and Spanish user interfaces are up-to-date.

    Explorer windows may be automatically closed during the upgrade install.

    The registration key for v11 is the same as the key for v10. If you are a registered user of EmEditor Professional v10 or v11, you can have your registration key resend at: https://www.emurasoft.com/support/send_keys.php

    The release version of this beta will be v12, and the registration key will be different from v11. Unless you have registered your licenses at Emurasoft Customer Center before November 1, 2011 or have subscribed Premium Support, you will need to purchase an upgrade when v12 is released. The v12 will be released soon.

    Thank you for using EmEditor Professional!

    #10508

    Yutaka Emura
    Keymaster

    We added “EmEditor Professional 12 New Features” page at:
    http://www.emeditor.com/modules/feature1/rewrite/tc_40.html

    Thank you!

    #10509

    Salabim
    Participant

    Hi Yutaka,

    Regarding to the tag highlighting, is there a chance you’ll “upgrade” this function to also take care of nested tags ?
    Right now, it only highlights extremely few tags (only a couple of opening- to ending tags on the same line).

    Is it ever going to take care of nested tags ?

    Currently, it highlights about 1

    tag for every 100 in the document, which is quite pity.

    For example, the div below does get detected & highlighted :

    <div id="logo_text">The Definitive Text Editor for Windows</div>

    This one doesn’t get detected & highlighted :

    <div id="language"><img src="tc_40_files/allflags2.png" alt="International Sites" usemap="#flags" height="21" width="324"> <a href="http://www.emurasoft.com/"><img src="tc_40_files/emurasoft-icon.png" alt="Emurasoft" title="Emurasoft Home Page" border="0" height="26" width="20"></a></div>
    #10510

    Yutaka Emura
    Keymaster

    Hello,

    This is because your example is not well-formed XHTML. should be closed with or it should be written as . I hope this information helps.

    Thanks!

    #10511

    Salabim
    Participant

    It was an example directly from your website source code though. lol. 😀

    #10512

    Salabim
    Participant

    BUG (since update to v11.1.11 beta)

    After opening & editing a Western European (ISO) document, pressing the save button, or closing the document causing the Save? window to appear gives a Choose document format (Unicode?) prompt offering to change the document format.

    This has never happened before, and the original document format was automatically respected when saving, not resulting in a prompt. 🙁

    #10513

    Yutaka Emura
    Keymaster

    Hello Salabim,

    1) My old website (emurasoft.com) is not XHTML, but HTML, so it is still valid ( can work without a closing tag). The tag on the first line can tell whether the page is HTML or XHTML.

    2) By default, HTML documents will not prompt to choose an encoding. This can be customized by selecting configuration properties, the File tab, click the “Saving…” button, and then set the “Save Unicode as HTML/XML Character Reference” check box.

    Thank you!

    #10514

    Salabim
    Participant

    Thanks for the fast reply Yutaka. 🙂

    1) I understand now, sorry because i’m not that knowledged about that material.

    2) The problem happened to be with a .cfg file (detected as default Text configuration) which I edit on a (close to) daily basis. I never had that multi-options prompt “Save as Unicode (UTF-……)” until i upgraded to the 11.1.11 beta.

    I got rid of the prompt by unticking Prompt when saving unicode as ANSI in the “Save…” options menu you referred to.

    I wonder why that option got changed all of a sudden.

    #10515

    Yutaka Emura
    Keymaster

    The Text configuration has this “Prompt when saving unicode as ANSI” checkbox set by default. The prompt appears only when a document contains a Unicode character (those characters that are unable to encode as specified encoding). I hope this makes sense.

    Thanks!

    #10516

    Salabim
    Participant

    Hmmm, that’s weird.

    I have EmEditor on my notebook too, I edit a copy of that same file there too on a daily basis, and my install there indeed does have the option “Prompt when saving unicode as ANSI” ticked, but i don’t get any prompt there. 😕

    PS. On my notebook, i don’t install beta versions, so there it’s the latest final 11.0.5. Only other difference is that on notebook i use the 64bit version, while on the PC it’s the 32bit version.

    #10542

    Deipotent
    Participant

    I have button style tabs enabled and if I move a button tab and then do a save, the tab moves back to it’s original position (in alpha order I believe), rather than staying in the position I moved it to.

    #10543

    Yutaka Emura
    Keymaster

    Hello,

    Is “Auto Arrange” checked for “Arrange Tabs By” sub menu of the context menu on the Tab?

    Thanks!

    #10544

    Deipotent
    Participant

    Yes, it’s enabled. However, if I manually move a tab, I would expect the tab to stay where I moved it.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Share with friends... Tweet about this on TwitterShare on FacebookShare on Google+Email this to someone