Forum Replies Created

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • atnak
    Participant

    Brilliant! I can confirm both problems are resolved in v17.1.4. Thanks!


    atnak
    Participant

    Thank you. However, I have tried v17.1.3 and there appears to be a slight mishap.

    Because if I scroll all the way down, nib moves past its bottom boundary and buries itself into the bottom button of the vertical scrollbar.

    The problem can be reproduced by having a document containing a large number of lines relative to the window size. For example, 8000 lines with the window height of 800px.

    I think it may be related to the fact that there’s a minimum height of 16px beyond which the nib will not shrink.


    atnak
    Participant

    Some old programs need the EOF character (0x1a),

    That’s something I never knew of! Thanks for the explanation.

    Regards,

    P.S.
    I did some searching on this mysterious 0x1A character that I’ll share here in case someone else is interested.


    atnak
    Participant

    To work around this, you can select the “Custom” for the Input, and then enter “$(DocText)” for the “Custom” text box, and make sure the “Add EOF” check box is cleared.

    Thanks for the update and workaround. I can confirm it works correctly with Custom input of “$(DocText)”.

    On the next version, I will make the “Add EOF” check box enabled even when “Selection” or “Document” is selected.

    I’m not altogether certain what the purpose of this is, since a real EOF is received by the external program when EmEditor closes the pipe.

    I tested with this program to confirm EmEditor is properly closing the pipe. I get the output “a$” to the input “a” when “Add EOF” is off, and “a<0x1a>$” when it’s checked.

    static class Program
    {
        static void Main(string[] args)
        {
            for (int c; (c = System.Console.Read()) != -1;)
            {
                System.Console.Write((char)c);
            }
            System.Console.Write("$");
        }
    }

    At the very least, I think the checkbox is ill-named as it can be confused with the real EOF (closing of an input stream) which that checkbox has nothing to do with. Maybe a name such as “Add &1AH (Ctrl-Z) byte” can avoid this confusion.


    atnak
    Participant

    cat command probably produces the EOF

    cat is really only an example. (Although what I said above is true for the cat.exe that I have.)

    The outcome is the similar with various other commands:

    SqlFormatter.exe regurgitates the 0x1A to the output.

    python.exe -m json.tool complains about “Extra data” at the exact line and column where that 0x1A byte is expected to be.

    This simple C# program will output the 0x1A on the end if specified through EmEditor’s “External Tools”. It will not do this if called through command prompt such as ‘Program.exe <a.txt >b.txt‘.

    static class Program
    {
        static void Main(string[] args)
        {
            for (int c; (c = System.Console.Read()) != -1;)
            {
                System.Console.Write((char)c);
            }
        }
    }
    in reply to: Select All & Paste resets EOL #17370

    atnak
    Participant

    Please go to Configuration Properties, File tab, New Files button, and select “LF Only (UNIX)” from the Return Method.

    Strange, I can’t get this to resolve the issue.

    I’m using “EmEditor Professional (64-bit) Version 13.0.6” and my system’s default encoding is “日本語 (シフトJIS)”.

    Properties for Current Configuration (txt) shows:

    • New Files… > Return Method: LF Only (UNIX)
    • Saving… > Return Method: No Change

    My test file is “Untitled.txt” (Return Method = LF Only (UNIX)) containing:

    a
    b
    c

    Important: EmEditor should be closed once after creating this file before attempting to reproduce.

    To reproduce, I simply open “Untitled.txt” from Explorer, check that the status bar shows “LF Only (UNIX)”, then hold down Ctrl and type A, C, V.

    in reply to: Select All & Paste resets EOL #17364

    atnak
    Participant

    And only until I press Enter one time after the ‘c’, then it switch to “LF Only (UNIX)”

    Oops, an amendment: You need to close & reopen the document between steps 3 and 4. Then, it’s not temporary.

    The “Tools > Customize… > Status > Return Method” has nothing to do with this situation at all as it seems.

    It has nothing to do with the cause. But you’ll be hard pressed to see the problem if you can’t see what the Return Method is in the status bar.

    in reply to: Select All & Paste resets EOL #17362

    atnak
    Participant

    Alternate steps to clarify the problem:
    1. “Tools > Customize… > Status > Return Method” should be checked
    2. Create a new document and type “a<Enter>b”
    3. Save the document, selecting “LF Only (UNIX)” as the Return Method in the Save dialog.
    4. Notice the Status Bar shows “LF Only (UNIX)”
    5. Ctrl-A to Select All, then type “c” (or alternatively, hit Ctrl-C to Copy followed by Ctrl-V to Paste)
    6. Notice the Status bar now shows “CR+LF (Windows)” <– Problem here

    in reply to: Select All & Paste resets EOL #17361

    atnak
    Participant

    Preserve (CR/LF) returns on Clipboard check box

    Thanks for the advice. However, I don’t think this helps.

Viewing 9 posts - 1 through 9 (of 9 total)