Forum Replies Created

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • in reply to: Alt+arrowkey for vertical selections #18108

    Bill_Stewart
    Participant

    I think it would be useful also. In the meantime I have emulated this with macros. First macro is verticalSelect.jsee:

    if ( (document.selection.Mode & eeModeMask) != eeModeBox ) {
      document.selection.Mode = eeModeBox;
    }
    

    Then four different macros for Alt+Shift+Left, Alt+Shift+Right, Alt+Shift+Up and Alt+Shift+Down keystrokes:

    #include "verticalSelect.jsee"
    document.selection.CharLeft(true);
    

    This macro would be verticalExtendLeft.jsee and you can bind to Alt+Shift+Left. Of course you will also need to create verticalExtendRight.jsee that contains

    document.selection.CharRight(true);
    

    and so forth for the other keystrokes. This solution is a little clumsy (and a bit slow because it is macros), but I like it better than switching selection modes.
    Bill

    in reply to: Multiple cursors in find?? #17667

    Bill_Stewart
    Participant

    How can you do this in emEditor?

    1. Select the text.
    2. Use Search->Replace dialog

    Find: ^(.+)$
    Replace with: \1.

    3. Enable “Use Regular Expressions” and “In the Selection Only” dialog boxes
    4. Click “Replace All” button
    Bill


    Bill_Stewart
    Participant

    Right, I forgot to include the line that declares EEID_FINDBAR_INCREMENTAL in my code. The code should be:

    var EEID_FINDBAR_INCREMENTAL = 4571;
    var eeStatus = editor.QueryStatusByID(EEID_FINDBAR_INCREMENTAL);
    alert(eeStatus);

    What I am saying is that QueryStatusByID(4571) always returns 2 regardless of the state of the incremental search button.
    I am using 13.0.6, x64 version.
    Bill

    in reply to: Tab / indent / auto indent question #10483

    Bill_Stewart
    Participant

    Thanks!

    Bill

    in reply to: Tab / indent / auto indent question #10481

    Bill_Stewart
    Participant

    Hi Yutaka,

    I downloaded latest 11.1.9 beta 32-bit portable and the problem is exactly the same: Uncheck “Use regular expressions”, and “ignore after” works. Check it again, and “ignore after” does not work.

    To reproduce, follow exact steps at beginning of thread.

    Thanks!

    Bill

    in reply to: Long Line Indicator #9608

    Bill_Stewart
    Participant

    Hi Yutaka,

    I would also like to have this feature in a future version.

    Thanks!

    Bill

    in reply to: Ctrl+PgUp or Ctrl+PgDn shortcut keys #9558

    Bill_Stewart
    Participant

    That works, thank you very much.

    Bill

    in reply to: Support for multi-key bindings #8405

    Bill_Stewart
    Participant

    Hello,

    Do I understand that EmEditor now supports multi-key bindings?

    Thanks!

    Bill

Viewing 8 posts - 1 through 8 (of 8 total)