Forum Replies Created

Viewing 25 posts - 26 through 50 (of 53 total)
  • Author
    Posts
  • in reply to: 19.3.1 x64 – Text shifting with arrow keys no longer works #26263
    tuska
    Participant

    Thank you for your prompt response.

    02.11.2019 19:22:
    I sent an email with all information including a video by email.

    I would like to add only that the “problem” when using the
    – file “C:\Program Files\EmEditor\EmEditor.exe” and
    – not using the file C:\Program Files\EmEditor\emedtray.exe
    occurs.

    Thanks in advance.

    in reply to: 19.3.1 x64 – Text shifting with arrow keys no longer works #26261
    tuska
    Participant

    I’ve checked that again now (2 tabs):

    The “problem” occurs in the 64 bit version (installed), and only with the first program start,
    when I use EmEditor

    – with a shortcut on the desktop –> “C:\Program Files\EmEditor\EmEditor.exe” or
    – with a button in file manager “Total Commander” –> command: “C:\Program Files\EmEditor\EmEditor.exe”

    If I move EmEditor to the systray with ESC and then open it with a double click,
    there is only 1 tab page left.

    This “problem” does not exist in the portable 64 bit version.

    If you still need the information about Customize Workspace, I can deliver it later.

    Is it possible to integrate a .png image file here directly (25,2 KB) or only via an external website (image hoster)?
    (I think I have seen a picture here directly in the forum … but I don’t know how to set it up)

    in reply to: Bookmarks removal after renaming/moving of a textfile #26244
    tuska
    Participant

    [… … or when opening a text file created with the 64 bit version with the 32 bit version and vice versa …]

    Sorry, I meant
    bookmarks are also lost when opening a text file created with the 64 bit version with the 32 bit version and vice versa.

    in reply to: Bookmarks removal after renaming/moving of a textfile #26243
    tuska
    Participant

    Outside of EmEditor the bookmarks are currently lost,
    when I copy, move or rename a file.
    [… … or when opening a text file created with the 64 bit version with the 32 bit version and vice versa …]

    in reply to: Bookmarks removal after renaming/moving of a textfile #26242
    tuska
    Participant

    Hello,
    thank you for your quick reply.

    Here are my settings:

    ☑ Save Cursor Position and Bookmarks
    Number of Days to Save: 3000
    ☑ Never Clear Bookmarks

    2. If the name of a file was renamed outside of EmEditor, EmEditor will not be able to see the changes.

    Thank you for that information, I didn’t know that.

    1. I am not sure if I understand your question. Copy a file from which folder to which folder?
    Can you please write a simple step-by-step to reproduce the issue?

    Here is a simple example, created with the 64 bit installed version:

    1. create the file Bookmarks.txt in D:\Data
    2. enter a few lines, e.g. 1,2,3,4,5,6,7,8,9,10 and create a bookmark in every second line
    3. save and close the file
    4. Copy the file D:\Data\Bookmarks.txt to I:\Data\Bookmarks.txt.
    5. when I open the file I:\Data\Bookmarks.txt, the bookmarks no longer exist.

    Currently I only have the possibility to use the function “Save As… F12”,
    to keep the bookmarks.

    in reply to: Suggest to change the behavior of "view->marks" #26177
    tuska
    Participant

    Thank you very much for checking and implementation!

    Personally I will mainly use the button “All Marks” in the future,
    as it meets my requirements best.

    Regards,
    Karl

    in reply to: Suggest to change the behavior of "view->marks" #26167
    tuska
    Participant

    With reference to what has been said before, it would be desirable,
    – if you could deactivate or activate the following selected menu items with the “Marks” button
    – taking into account 2 exceptions

    Example:
    ☑ Newline Characters
    ☑ End of File
    ☑ Tabs
    ☑ Spaces
    ☑ Wide Spaces
    ☑ CR and LF with Different Marks –> PLEASE LEAVE UNCHANGED! (e.g. unticked) analogous to the behavior of the menu item “All Marks”
    ☑ Control Characters
    ☑ Indent Guides
    ☑ User-Defined Guides –> PLEASE LEAVE UNCHANGED! (e.g. ticked) – this is currently the case! ***)

    ————-

    ***) Menu “View” – “Marks” – ” All Marks” –> The tick is REMOVED: “User-Defined Guides”

    Here, too, I would plead for the point “User-Defined Guides” to be left unchanged
    because there is a separate menu item for this purpose anyway: “Add/Remove User-Defined Guide”.
    [and I personally regard the line as a hint for a “line break”].

    ————-

    Please therefore ask for examination.
    Thank you!

    in reply to: Suggest to change the behavior of "view->marks" #26165
    tuska
    Participant

    Thanks for the implementation!

    I noticed the following:
    – Right click on buttonbar – Customise This Toolbar…
    – Available button: “Marks” –>

    When I press the “Marks” button, the “Spaces” are not displayed,
    other characters, e.g. “Newline Characters”, “End of File” and “Tabs” are shown.

    Can you please check and add “Spaces” to that?

    in reply to: Suggest to change the behavior of "view->marks" #26158
    tuska
    Participant

    Or is this requirement is reasonable?

    For me it is.
    Support +

    tuska
    Participant

    I would just like to add the following:

    It is used
    1. EmEditor – installed – english language
       C:\Program Files\EmEditor\EmEditor.exe
    2. EmEditor – portable – german language (german = deutsch)
       D:\Daten\Programme\TotalCommander\TCD_USB-Stick\TC32-64USB\Tools\EmEditor-portabel\EmEditorProfessional_64-bit_portabel\EmEditor.exe

    Otherwise, all settings are the same.

    ——————–
    Windows 10 Pro (x64) Version 1903 (OS Build 18362.295)

    in reply to: Outline | Outlining | Level 2 – 5 | Question #26108
    tuska
    Participant

    By chance I found the answer to point 1. myself:
    Menu “Tools” > “Properties for All Configurations” – “Outline”…
    Here you have to create the entries for the outline points under “Find”, e.g.
    < = Level 1
    [ = Level 2
    { = Level 3
    & = Level 4
    * = Level 5

    If necessary, in the menu “Tools” > “Properties for Current Configuration Alt+ENTER” in the relevant document
    still require an adjustment.

    For point 2. I tried Google with the following query: Outline site:https://www.emeditor.com
    and found a suitable answer for me under point 1.:
    Solution: https://www.emeditor.com/forums/topic/how-to-customize-the-outline-plugin/
    Each level ends when it find the same level begin.

    Please consider my request as closed.

    tuska
    Participant

    On the basis of further tests this can be clarified as follows:
    The error seems to occur randomly with the installed version.

    When the portable version opens a text file created with the installed version,
    then the coloring is not visible in the bookmarks (in the active portable version).

    tuska
    Participant

    Hello,
    Several other tests have shown the following:

    Installed version active:
    1. Open “Bookmarked_colored_with installed version created.txt”: OK
    2. Open “Bookmarked_colored_with installed version created_2.txt”: OK
    3. Open “Bookmarked_colored_with installed version created_3.txt”: NOK (not OK)
    3a Open “Bookmarked_colored_with installed version created_3a.txt”: OK
    3b Open “Bookmarked_colored_with installed version created_3b.txt”: OK
    4. Open “Bookmark_colored_created_with portable version.txt”: OK
    5. Open “Bookmark_colored_created_with portable version_1.txt”: NOK (not OK)
    6. Open “Bookmark_colored_created_with portable version_2.txt”: OK

    Portable version active:
    1. Open “Bookmarked_colored_with installed version created.txt”: NOK (not OK)
    2. Open “Bookmarked_colored_with installed version created_2.txt: NOK (not OK)
    3. Open “Bookmarked_colored_with installed version created_3.txt”: NOK (not OK)
    4. Open “Bookmark_colored_created_with portable version.txt”: OK
    5. Open “Bookmark_colored_created_with portable version_1.txt”: OK
    6. Open “Bookmark_colored_created_with portable version_2.txt”: OK

    The error seems to be randomly.

    tuska
    Participant

    Hello,
    thanks for your prompt reply.

    The problem is that I have saved the same settings for the bookmarks in both the installed and portable version,
    but the color is not displayed as stated above.

    tuska
    Participant

    2LTT
    Thank you for this additional tip!
    But I won’t make a suggestion, because the existing functions are sufficient for me.

    tuska
    Participant

    On a second thought:
    Probably only the first line in which the continuous text starts is displayed in multi-line mode.
    More is actually not necessary.

    tuska
    Participant

    Now I have one last question: Button “Extract” in the “Find”-window:
    ☑ Use Output Bar | Extract Options: Display File Names and Lines

    Example:
    9
    09
    2
    4
    24
    42
    123
    5467
    —-
    ◉ Regular Expressions: (?<![0-9])[24](?![0-9])
    Klick on button “Find Next” and then on “Extract” brings “Output”:

    “(?<![0-9])[24](?![0-9])” Untitled-3

    Untitled-3(4): 2
    Untitled-3(5): 4

    Test: OK
    —-
    ◉ (None) – ☑ Multiline
    Same example: 2 Ctrl+enter, 4 Ctrl+enter
    Klick on button “Find Next” and then on “Extract” brings “Output”:

    “2
    4
    ” Untitled-3

    Untitled-3(4): 2

    Untitled-3(5): 4 seems to be missing for me in “Output”-box
    —-
    ◉ Escape Sequence – without Multiline
    Same example: 2\n4\n
    Klick on button “Find Next” and then on “Extract” brings “Output”:

    “2\n4\n” Untitled-3

    Untitled-3(4): 2

    Untitled-3(5): 4 seems to be missing for me in “Output”-box
    —-
    With the remaining three options in “Extract Options…” I suspect partially similar combinations,
    i.e. only a partial output in the “Output” box.
    —-
    For me there would be one line missing in the “Output” box in the example above.
    Can someone please confirm this or tell me how to understand this constellation?

    tuska
    Participant

    2LTT
    Thank you for the detailed description and clarification of this function!
    That’s how I understood this function now.

    I just wanted to make a short summary of this function for me as a reminder.
    —–
    Thanks again to everyone for their support!

    tuska
    Participant

    2LTT
    Thank you very much for your support!

    I have read everything from you carefully.
    Now everything is working as expected.

    For me personally, I have noted the following as a brief summary:
    With CTRL + ENTER and option “Multiline” in the “Find”-window, it is possible to search for a cohesive search term over several lines.

    Simple formulation for valid examples for CTRL + ENTER:
    – Example1: 1,2,3,4,5 –> Search for: 2,3,4 (and not for 2,4) –> DO NOT press CTRL+ENTER after 4!
    – Example2: abc def, ghi jkl, mno pqr –> Search for: (1)def (2)ghi jkl (3)mno –> after mno do NOT press CTRL+ENTER anymore!

    Regards,
    Karl

    tuska
    Participant

    2LTT
    Many thanks for the comprehensive and detailed information.

    That box in Multiline mode is not a “list”, if you thought it was.

    Yes, I mistakenly assumed that.

    >… are marked in green.
    > EmEditor cannot highlight multi-line matches with colors.
    > A match will be highlighted with colors unless it’s multi-line.

    Yes, that’s why I wrote above:

    > Please regard this text as irrelevant.
    > That was a misunderstanding on my part.

    I think I understand the subject a little better now, but between theory and practice there’s still a gap with me.

    Example:
    1
    2
    3
    4
    5

    only matches as a whole:
    2
    3
    4

    1. RegEx –> OK
    2. Multiple-lines –> ?

    Please watch the video:
    20190707_13.32.43_Video__1368x836_00.02.24_Multiple-line string as a search string.wmv

    What am I doing wrong with “Multiline” or what else is a mistake of mine?

    tuska
    Participant

    For me, there is currently only one question left unanswered: CTRL+ENTER (in Multi-line mode) – (see previous post):
    If I do CTRL + ENTER as in the picture above, I won’t get any results with the following options:
    ☑ Multiline
    ◉ (None)
    ◉ Regular Expressions
    ◉ Escape Sequence
    Is this a bug of EmEditor or an application error of mine?
    Are multi-line queries only allowed with the option ◉ Regular Expressions?

    tuska
    Participant

    Hi Mr KT,
    (?<![0-9])[24](?![0-9])
    works perfectly!
    Thank you very much.

    tuska
    Participant

    2Patrick C
    Thank you for your code, which is the solution for my example above.
    Your example also finds the number 42 – this should not be found.

    I don’t know if there is a solution:
    Only 2 and 4 should be found, i.e. exactly:2 and exactly:4.

    If there are any combinations in which the numbers 2 and 4 are contained,
    such as 1024, 42, 4242, 1524, 2415, 124215, 754224, etc., then the numbers should not be found/marked.

    regex101 dot com is also my favorite site because it offers explanations – but I am a complete beginner…

    tuska
    Participant

    If you want to search for a multi-line string, usually you have to match the exact number of the lines:
    Does this mean that I have to go to the end of each text document before searching to determine the exact number of lines?

    And note that EmEditor cannot highlight multi-line matches with colors.
    Mmmh, with
    ☑ Multiline
    ◉ Regular Expressions
    (^2$|^4$)
    in a .txt file the numbers 2 and 4 are marked in green.

    Please regard this text as irrelevant.
    That was a misunderstanding on my part.

    For me, there are currently only two questions left unanswered:
    – CTRL + ENTER (see previous post)
    Exact search for a number with RegEx, e.g. find 2 and 4 in a range from 1,2,3,4,5,24 (see previous post).

    tuska
    Participant

    2LTT
    Thank you very much for your examples with RegEx and efforts to bring the topic closer to me.
    Unfortunately, I’m afraid I’m more confused now than before.

    Ctrl+Enter (in Multi-line mode) = \n (in Single-line mode).

    If I do CTRL + ENTER as in the picture above, I won’t get any results with the following options:
    ☑ Multiline
    ◉ (None)
    ◉ Regular Expressions
    ◉ Escape Sequence

    Is this a bug of EmEditor or an application error of mine?
    Are multi-line queries only allowed with the option ◉ Regular Expressions?

    If you want to search for a multi-line string, usually you have to match the exact number of the lines:

    Does this mean that I have to go to the end of each text document before searching to determine the exact number of lines?

    And note that EmEditor cannot highlight multi-line matches with colors.

    Mmmh, with
    ☑ Multiline
    ◉ Regular Expressions
    (^2$|^4$)
    in a .txt file the numbers 2 and 4 are marked in green.

    In the example in the picture I wanted to find exactly the numbers 2 and 4 in a range from 1 to 5, with or without RegEx.
    To complicate matters, I would also like to add the number 24 to the list and this number should not be marked.
    Unfortunately, I do not know how it would be possible to make an exact definition, so that only numbers 2 and 4 would be marked.

    Perhaps it would be possible if you or someone else could answer these questions for me.

Viewing 25 posts - 26 through 50 (of 53 total)