Forum Replies Created

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts

  • thanksgod
    Participant

    Hi Yutaka!!

    Sorry for the late reply, was too busy last this week, but when I saw your reply including releasing the minor version, then I downloaded and installed, then WOW WOW WOW, it’s displaying Thai font correctly on both WinXP(as it used to), and Win 7 NOW!!!.

    btw, I should report this bug since v12.0.1 lol

    GREAT JOB, Yutaka

    Thank you so very much again!!! :-D :-D


    thanksgod
    Participant

    Hi, Yukata

    UseUniscribe DWORD
    UseWidthArray DWORD

    I’ve tried both 4 combinations

    UseUniscribe:UseWidthArray

    0:0
    0:1
    1:0
    1:1

    It just gives me the same result as the previous one when I haven’t had that 2 values in the registry (by DEFAULT after Fresh installation)

    Cheer!!


    thanksgod
    Participant

    Hi, mguttman
    Sorry, if I answer instead of the OP, as I’m using Thai language too. OK, Thai language is written left-to-right just like the English language.

    However, there is some character that need to be written “above” and “under” another character, which does Emeditor to make the “unintentional whitespace” between those characters just like the picture that OP has shown above.

    Hi, Yukata

    Thanks for the advice, Yukata.
    BTW, I have put those 2 DWORDs values as you suggested but still doesn’t work. Is there any other solutions please?

    Cheers!!


    thanksgod
    Participant

    Yes I’ve been experienced this problem since v12.0 and ONLY in WIN7 & WIN8 (winXP is working fine). And just like the OP said, in other word/text processors are working CORRECTLY, except EmEditor.

    haha I thought I’m the only user that encounter with this “THAI” language problem.

    FYI, for me it’s not just only for Sara Am, but it’s working INCORRECTLY for all “THAI” fonts as far as I’ve tried.

    Actually, I should report this since the release of v12.0 already, but I thought it’s just only me who faced this problem and I believed it was because of my windows had problem. Now, when there is some people got the similar issue as mine, so now I’m quite sure that there must be something wrong with the Emeditor.

    Hope you can fix and release the minor version very soon.

    Thank you so much Yukata!!

    in reply to: EmEditor Professional v13 beta 5 (12.9.4) released! #11000

    thanksgod
    Participant

    Hi, Deipotent

    I’ve just tried your examples on both 12.0.11 & 13 beta 5.
    I’ve got the correct matching, I mean only 3 matches found.

    What else (from your example), did you get when you do find using “bcd”?

    Cheers!

    in reply to: EmEditor Professional v13 beta 5 (12.9.4) released! #10997

    thanksgod
    Participant

    Hi!!

    Thanks for keep working hard toward the new version.

    Recently, or maybe sometimes, I usually use the Keyboard Map (Help > Keyboard Map…) to “Configure and/or See” the shortcut that I need, but I found it’s a bit inconvenient that while “Keyboard Map” window is opening, I can’t do anything in the Emeditor “Main” window unless I closed “Keyboard Map” window first.

    Many times, that I “forgot” or want to re-map the shortcut key because some of my other programs’ shortcut keys using the SAME in the Emeditor’ shortcuts key, so I have to remap them a lot, and that make me forget it a lot. lol

    Say it shortly, I hope you can make the “Keyboard Map” window separates from the “Main” window, So I can do anything in the “Main” window while I leave the “Keyboard Map” window opens.

    Thanks!!!

    edit:Sorry!! if this shouldn’t be in the Beta section because it also happens with the Main version too, but I think it’s maybe good to post here, so you can put this change into this beta version towards the Next Main version.

    in reply to: EmEditor Professional v13 beta (12.9.0) released! #10967

    thanksgod
    Participant

    Oh

    That’s cool Yukata, I’ve just seen there are several beta versions out, and I had a look on the new features. Oh, it really make me excited!!!. Of course I have to try those new features right now!!!

    I will have a try on each of the new feature one-by-one :)

    I’m really sure, this BIG change including will make my life and others much much more convenient.

    This one BIG change, is not the April’s fool joke, is it?

    Joking!! :-D :-D

    BTW,

    And you even minimize the size of the EE files even more on every release it seems

    I also just noticed one thing, and I don’t know why because normally I usually see the x32 edition of others software will have the Smaller size than x64 edition for the same version of software, BUT why Emeditor’s edition (x32 & x64) sizes are just opposite.

    I mean for the Emeditor, x32 edition has a size bigger than x64 edition? could you please tell me why is that?

    It’s time for me to try out the beta now :)

    Thanks again!!!!!


    thanksgod
    Participant

    Hi,

    Yeah, that’s a good way for me as a learner too. :)
    I like learning something new everyday as much as I can >_<

    And also thanks for letting me know about the safety value, yeah, my computer not that too old, so it should be fine. lol

    BTW, Since I’ve using EmEditor, I’ve found out from you and the Yukata that it provides most of the essential tools that suite for the beginner up to advanced or professional users.

    And EmEditor usually makes me very surprise that there are many tools that I need, but it hides somewhere (or maybe I don’t know that yet) just like easter egg in Microsoft or oldschool MSN. lol

    Thanks!!!!


    thanksgod
    Participant

    Hi, Stefan

    First of all, you help me again, thank you so much >_< Also thank you for letting me know about
    “enable “[X] Regular Expression can match new line characters”

    That’s REALLY useful for me in the future too.

    However, @ 1st, it doesn’t work, so I read further “Help” about that, and it says NOT to forget to specified the number in “Additional Lines to Search for Regular Expressions” text box to be more than ZERO. So I just enter “100”, and it banged it works like the pattern you gave me. Yes!!!

    For the (?s) & [sS] I found it about couple hours ago via stackoverflow
    And I believe many newbies like me doesn’t know that too, as you can see the number of the rating currently (138) lol that’s a lot.

    Also thank you for giving me not just one but more choices to solve my issue, and also for the future reference website too.

    BTW, I have one more question, for the ” Additional Lines to Search for Regular Expressions”, is it SAFE to enter the value very high (I mean 100 for example). I believe it should be ok while I’m using the Non-Greedy (?) mode, isn’t it?

    Thank you again Stefan for quick help :-) :-)


    thanksgod
    Participant

    anyone? please >_<

    BTW, does Emeditor has “dotall” regex?

    in reply to: Some Typo in Menu Bar #10887

    thanksgod
    Participant

    Oh yeah, you’re correct.

    I misread it actually, :oops:

    “Export all settings into a registry file.”

    BUT, I read as “Export all settings into a registry.”
    Same for the “ini“, I misread the word “file(s)”

    that’s why it sounded strange to me,

    However, I suggest using the word “as” instead of the word “into”.

    For the “Import all settings from a registry file.”, yeah it’s ok, but at that time, I might confused with the above 2 export sentences. :lol:

    in reply to: Is there any way to disable Large File Controller? #10758

    thanksgod
    Participant

    Hi, Stefan

    Thank you for the help, but could you please be more specific.
    I cannot find those menu in “Help” or any others on “Menu Bar”

    Do you mean
    “View” > and untick “Large File Controller”?
    Maybe I’m wrong.

    Please help me further.

    Thank you so much

    ——————————-
    Edit:

    Oh I see you what you mean, it’s under the following menu;
    “Tools” > “Customize” > “File” tab > then untick “Display Large File Controller when a large file is opened”

    Futhermore, I just realize that we can also change the number of the “Minimum File Size” for the “Large File Controller” to open automatically too.

    It’s in the following menu;
    “Tools” > “Customzie” > “Advanced” tab > then change the number of MB you’d like in the “Minimum File Size to Open Asynchronously”

    Thank you again, Stefan, for your help !! :pint::pint:

    in reply to: Multiple Delimiters please!! #10693

    thanksgod
    Participant

    Hi, Yukata

    Oh my god, I’ve never known that we can search for the Keyboard shortcuts which is in “Help” menu :oops::oops:. Normally, if I just want to map any keyboard shortcut, I just go directly in Tools > Configuration > Keyboard , and then I have to find in the “Category” and then “Commands”, very difficult for me to find some setting.

    Anyway, thank you so much for letting me know the “Keyboard Map” which, it’s a GOLD :-D :-D , so simple for searching.

    Now I’ve already define the shortcut key like you suggested already. AND yeah !!Very Convenient!! indeed.

    Thank you so much again Yutaka for your help :-):-)

    in reply to: Multiple Delimiters please!! #10691

    thanksgod
    Participant

    Hi,

    Thank you Yutaka for the quick reply, it’s ok I undersand that, I will wait for the next major version then :)

    BTW, is there any a way to do it quick than just go through each step Tools > Configurations > File

    I mean can I create a keyboard shortcut (tools > configurations > Keyboard > Category (Edit) > Commands (User-Defined DSV Mode)
    or some way similar to that?

    As I cannot find the shortcut for that, I only see the command “User-Defined DSV Mode”, but not “Delimiter” command.

    Thank you for your help :-)

    in reply to: Hi, Can anyone help me on "Sorting" please #10410

    thanksgod
    Participant

    Hi, Stefan

    OMG, how easy it is, so now I don’t have use Microsoft Word anymore!!!

    Thank you so much for your solution. It works Wonderfully!!!

    Cool Cool Cool :pint::pint::pint:

    Thank you sir!! :-D:-D:-D

Viewing 15 posts - 1 through 15 (of 17 total)