Forum Replies Created

Viewing 15 posts - 1 through 15 (of 194 total)
  • Author

  • LTT

    How about moving the “Batch” down to the bottom, since the Replace box is quite wide now. And thus we can drag to make it even wider than side-by-side.

    And please consider “Pseudo-Maximize” behavior for such windows.
    See “Issue D” in:
    Double-clicking on title bar is more quick and convenient than dragging the border. And Maximize/Restore is much better than changing the size now and then.

    Issue 1:
    Drag to make Replace box to its minimal width.
    Open Batch.
    Drag to enlarge the width.
    Drag to minimize the width.
    Close Batch.
    The width now is not minimal.

    Issue 2:
    The TXT type exported from Batch is not correct.
    Only the “Find” column is included.


    Do you just want to paste and replace all the strings at a time?
    See if these helps:

    Method 1:
    Put the source strings into EmEditor. (They should be one per line.)
    Turn on any CSV mode.
    Click the column header (above the ruler) to select the whole column.
    Copy. (So they are copied as a column via EmEditor.)
    Now you use “Select All” in your case.

    The target should be a vertical selection, or a block of multiple selections, i.e. one string per line (like in your case).

    Method 2:
    Add a CSV format (with ” as the delimiter in your case).
    In such a CSV view, the strings in “” are in an individual column.
    Turn on Cell Selection mode. (Now the delimiters are hidden. And you can work like in Excel.)
    Copy the source strings in another app. (Or copy them as a column via EmEditor as mentioned in Method 1.)
    In EmEditor, click the first cell that your paste begins (i.e. you can paste a block of cells, as well as the whole column).
    (You can even paste 2+ columns at a time.)

    Means may vary, e.g. Cell Selection mode is not necessary in some other CSV cases.
    A smart CSV view often makes the job easy.

    in reply to: Search #25665



    See the image.
    Ctrl+click 22222, 55555, and 88888 in the same line (wrapped).
    ** See the frame issue. As if they were one selection.

    in reply to: Indent #25663


    Your way doesn’t work for me.

    If the lines are all empty, I have to:
    Make a vertical selection.
    Type any character instead of Tab.
    Type Tab.

    If the lines are not all empty, I have to:
    Make a vertical selection.
    Type any character instead of Tab.
    Type Tab.
    Type Backspace (to delete the character).

    (The way mentioned in A works for either case.)

    Ctrl+click to make 2 or more points in the same line.
    Use “Increase Line Indent” command.
    ** The selection positions from the 2nd one are not correct.

    About Issue 1:
    I still suggest that it would be better if Tab/Shift+Tab could differ from the “Increase/Decrease Line Indent” commands.

    Before the change you made for issue 1, one can do this:
    Select lines partially.
    Type Tab (and Ctrl+Z).
    Now the lines are selected entirely.

    This is a quick way to select lines, especially when the lines are long and/or wrapped, and/or one is not willing to operate on the left edge, etc.
    The difference extends the use.

    in reply to: Line selection #25655


    If Suggestion 1 will not be considered as a solution, an option for this would be welcome.
    Thank you.

    in reply to: Menu IDs in macros #25651


    I thought it twice.
    This can be a new feature.
    I suggest adding a new flag: eeMenuShowKey.
    So if one is really using a command in a macro menu, he can control whether the key should be shown.

    in reply to: Horizontal scroll #25648


    Maybe was a false alarm. Sorry.

    in reply to: DirectWrite #25647


    Thank you for your investigation.
    Forget it if it’s not a common issue.

    in reply to: Selecting Multiple Columns in CSV #25480


    To select multiple contiguous columns, just drag in the column header (above the ruler), e.g. form 2 to 5, as same as in Excel.

    Shift+clicking also can be used in the column header.
    However, @Yutaka, there’s a bug:
    Click 2 in the column header.
    Shift+click 5.
    ** Only column 2+3+4 are selected.
    (Though Shift+dragging is OK.)

    in reply to: Indent #25479


    Wrap by Window.
    Enable “Wrap Indent”.
    Add a long line so it wraps.
    Indent the line.
    ** Its wrapped lines don’t show the indent gaps.
    ** While cursor position(s) in its wrapped lines obey “Wrap Indent”.


    EmEditor saves shortcut keys per configuration.
    So is it because that, you changed the keys in configuration A, but now you are using configuration B?
    If you want to use only one set of keys, mind that the “All Configurations” option is checked in “Keyboard Map” window when you change keys.

    If this does not resolve your issue, please describe an example step by step. Maybe I can help you further.

    in reply to: Middle-click on a macro menu #25464


    One of my “Active String” settings:
    String Enclosed by Double Quotation Marks: Right Clicked = Run Macro.

    The macro pops up a menu.
    The stuck issue also occurs on this menu.

    in reply to: Indent #25462


    The C above is not correct. Please ignore it.

    Suggestion 1:
    In some editors (e.g. UltraEdit, Notepad3), an auto-indent is added in 2 steps (the newline character, then the indent). Thus it can be undone in 2 steps.
    So when I add a new line but don’t want to indent it, I just press Enter key and then Ctrl+Z.
    This is really convenient, since an indent is often not just a single character.

    Suggestion 2:
    Select some indented lines.
    Use “Select Ending of Lines” command.
    Press Enter key.
    How about indenting all the new lines (but in the manner mentioned in Suggestion 1)?

    “Indent Column” in “All Commands” menu needs an “s”.

    in reply to: Multiple Selection Editing #25458


    Enable “Keep selections while typing in multiple selections”.

    xx oo
    oo xx

    Select all “xx” (or “oo”, to see different result).
    (Press Esc once, to see different result.)
    Press Enter (or use “Insert CR/LF/CR+LF” command) 2+ times.
    ** Extra spaces appear in the selections.
    ** And note the difference (in length of selection) when using “Insert CR+LF” command.

    You use “CR+LF” in other places. So how about also changing the “Insert CR and LF” command name?

    Make multiple selections.
    Type a letter.
    Undo. (The multiple selections persist.)
    Switch to another wrap mode.
    ** The multiple selections are canceled.
    (Redo doesn’t has the issue.)

    Make 2 selections in the same line.
    Use Shift+Left/Right to extend the selections.
    ** The 1st selection will collapse once either cursor goes into the other selection.
    In UltraEdit, they merge as one. But I don’t see why/when we should use it this way.
    I think an “ideal” fix (if possible) could be: Prevent the cursor from moving any further once it touches the neighbor selection, in order to keep the existing selections individual, in case one still wants to change them (e.g. move the cursors back).

    In UltraEdit, Ctrl+Click can remove a 0-width point when in multiple-selection/point mode.
    ** In EmEditor, I have to extend it before removing it. (Though “Deselect Top/Bottom Selection from Multiple Selections” command doesn’t has the issue.)

    + Suggestion 3:
    In UltraEdit, Left/Right key also can be used to move the multiple cursors among the lines. (Shift+←↑↓→ to extend multiple selections)
    Actually, in UltraEdit, every cursor in multiple-cursor mode behaves unconfinedly and naturally, just as the single cursor.

    Issue 5:+
    Select All Occurrences.
    Press Home (or End).
    Pressing Backspace (or Del) key does nothing, but is added into the Undo history.

    in reply to: Snippet #25457


    Go on with the last example above:
    Do the steps and Undo once.
    ** The result is not correct.
    It should undo the “()” only.

    Another example:
    Select “123” and run this snippet: ${0:${SelText}}$0
    (Now it should be “123123” with the left half selected.)
    Press Left or Right key.
    Type “xxx”.
    ** An “x” remained.

    Should be able to quit the snippet inputting mode by pressing Esc key.

    Select “xxx” and run this snippet: ${1:?}${2:${SelText}}$1$0
    By pressing Enter key I wanted to insert a new line before and after “xxx” but failed.
    Is it possible to make it support new lines in such cases?

Viewing 15 posts - 1 through 15 (of 194 total)